diff mbox series

[bug#66690,v2,4/8] gnu: Add python-cwlformat.

Message ID baa3a86661953e6b6841244039be1a7f99b929e3.1708029746.git.arunisaac@systemreboot.net
State New
Headers show
Series Upgrade cwltool | expand

Commit Message

Arun Isaac Feb. 15, 2024, 8:46 p.m. UTC
* gnu/packages/bioinformatics.scm (python-cwlformat): New variable.

Change-Id: Ib2d79e350ab100c61c7afe2d5d3eafc72146e493
---
 gnu/packages/bioinformatics.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 75cfad51a6..48e56945b3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5138,6 +5138,33 @@  (define-public python-scrublet
 doublets in single-cell RNA-seq data.")
     (license license:expat)))
 
+(define-public python-cwlformat
+  (package
+    (name "python-cwlformat")
+    (version "2022.02.18")
+    (source
+     ;; The PyPI tarball is missing Readme.md. Readme.md is required for the
+     ;; build.
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rabix/cwl-format")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0agkz2w86k91rc9m5vx5hsqi5nm6fcmzkng6j99hjapz0r9233ql"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-importlib-resources
+           python-ruamel.yaml))
+    (home-page "https://github.com/rabix/cwl-format")
+    (synopsis "Prettifier for CWL code")
+    (description "@code{python-cwlformat} is a specification and a reference
+implementation for a very opinionated @acronym{CWL, Common Workflow Language}
+code formatter.  It outputs CWL in a standardized YAML format.")
+    (license license:asl2.0)))
+
 (define-public cwltool
   (package
     (name "cwltool")