diff mbox series

[bug#66690,v2,2/8] gnu: python-ruamel-yaml: Update to 0.18.6.

Message ID 14917e292b584625ac25971a4b02cfef83101b9e.1708029746.git.arunisaac@systemreboot.net
State New
Headers show
Series Upgrade cwltool | expand

Commit Message

Arun Isaac Feb. 15, 2024, 8:46 p.m. UTC
* gnu/package/serialization.scm (python-ruamel-yaml): Update to 0.18.6.
(python-ruamel.yaml-0.16): New variable.
* gnu/packages/package-management.scm (conda)[inputs]: Replace
python-ruamel.yaml with python-ruamel.yaml-0.16.

Change-Id: Iff9eeeae043c9547d93a6c780f0c30bd760490d9
---
 gnu/packages/package-management.scm |  3 ++-
 gnu/packages/serialization.scm      | 16 ++++++++++++++--
 2 files changed, 16 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c1ad613bee..5d6bc47b8b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2022, 2023 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2023 jgart <jgart@dismail.de>
 ;;; Copyright © 2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1251,7 +1252,7 @@  (define-public conda
            python-pyyaml
            python-requests
            python-responses
-           python-ruamel.yaml
+           python-ruamel.yaml-0.16
            python-tqdm
            ;; XXX: This is dragged in by libarchive and is needed at runtime.
            zstd))
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 963028c734..240646748b 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -721,14 +721,14 @@  (define-public python-msgspec
 (define-public python-ruamel.yaml
   (package
     (name "python-ruamel.yaml")
-    (version "0.16.13")
+    (version "0.18.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "ruamel.yaml" version))
        (sha256
         (base32
-         "0hm9yg785f46bkrgqknd6fdvmkby9dpzjnm0b63qf0i748acaj5v"))))
+         "06rimidc9nb3i3r90n3a1zwf0qxw24zqykb3wpxwd1p72yifc9wb"))))
     (build-system python-build-system)
     (native-inputs
      (list python-pytest))
@@ -747,6 +747,18 @@  (define-public python-ruamel.yaml
 style and key ordering are kept, so you can diff the source.")
     (license license:expat)))
 
+(define-public python-ruamel.yaml-0.16
+  (package
+    (inherit python-ruamel.yaml)
+    (version "0.16.13")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ruamel.yaml" version))
+       (sha256
+        (base32
+         "0hm9yg785f46bkrgqknd6fdvmkby9dpzjnm0b63qf0i748acaj5v"))))))
+
 (define-public python-ruamel.yaml.clib
   (package
     (name "python-ruamel.yaml.clib")