diff mbox series

[bug#63866,07/16] gnu: Add perl-list-someutils-xs.

Message ID b76287eef64cb744605b12efa03c3953aeebd033.1685767964.git.gemmaro.dev@gmail.com
State New
Headers show
Series Add tidyall and some tidiers. | expand

Commit Message

gemmaro June 3, 2023, 5:05 a.m. UTC
* gnu/packages/perl.scm (perl-list-someutils-xs): New variable.
---
 gnu/packages/perl.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a394b353b44..9c80d44df0f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6535,6 +6535,29 @@  (define-public perl-list-someutils
 portions of this module couldn't be compiled on this machine.")
     (license (package-license perl))))
 
+(define-public perl-list-someutils-xs
+  (package
+    (name "perl-list-someutils-xs")
+    (version "0.58")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/D/DR/DROLSKY/List-SomeUtils-XS-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "15xjnkjj4yxv1qn9krsbkzzkm51hibg2k3lf5767j6s848k4v7jg"))))
+    (build-system perl-build-system)
+    (arguments
+     `(#:tests? #f)) ;tests need perl-list-someutils
+    (home-page "https://metacpan.org/release/List-SomeUtils-XS")
+    (synopsis "XS implementation for @code{List::SomeUtils}")
+    (description
+     "@code{List::SomeUtils::XS} is a XS implementation for
+@code{List::SomeUtils}.  There are no user-facing parts here.  See
+@code{List::SomeUtils} for API details.")
+    (license license:artistic2.0)))
+
 (define-public perl-mailtools
   (package
     (name "perl-mailtools")