diff mbox series

[bug#63866,14/16] gnu: Add perl-pod-tidy.

Message ID 5e545f34464d380788a5d61988bb4720354799b6.1685767964.git.gemmaro.dev@gmail.com
State New
Headers show
Series Add tidyall and some tidiers. | expand

Commit Message

gemmaro June 3, 2023, 5:05 a.m. UTC
* gnu/packages/perl.scm (perl-pod-tidy): New variable.
---
 gnu/packages/perl.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d731d2e8389..a89ccef5f14 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8996,6 +8996,33 @@  (define-public perl-pod-spell
 mystery words like \"@code{$thing}\" or \"@code{Foo::Bar}\" or \"@code{hashref}\").")
     (license license:artistic2.0)))
 
+(define-public perl-pod-tidy
+  (package
+    (name "perl-pod-tidy")
+    (version "0.10")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/J/JH/JHOBLITT/Pod-Tidy-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "1gcxjplgksnc5iggi8dzbkbkcryii5wjhypd7fs3kmbwx91y2vl8"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build perl-encode-newlines perl-test-cmd))
+    (propagated-inputs (list perl-io-string
+                             perl-pod-parser
+                             perl-pod-wrap
+                             perl-test-distribution
+                             perl-text-glob))
+    (home-page "https://metacpan.org/release/Pod-Tidy")
+    (synopsis "Reformatting Pod processor")
+    (description
+     "This module provides the @emph{heavy lifting} needed by the
+@code{podtidy} utility although the API should be general enough that
+it can be used directly.")
+    (license license:perl-license)))
+
 (define-public perl-posix-strftime-compiler
   (package
     (name "perl-posix-strftime-compiler")