diff mbox series

[bug#63866,04/16] gnu: Add perl-specio-library-path-tiny.

Message ID 908048a7c76180863ed5c23dda44e4ac7d574c83.1685767964.git.gemmaro.dev@gmail.com
State New
Headers show
Series Add tidyall and some tidiers. | expand

Commit Message

gemmaro June 3, 2023, 5:05 a.m. UTC
* gnu/packages/perl.scm (perl-specio-library-path-tiny): New variable.
---
 gnu/packages/perl.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5c6b1bb4b79..c78f0460a9d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9575,6 +9575,29 @@  (define-public perl-specio
 type.")
     (license license:artistic2.0)))
 
+(define-public perl-specio-library-path-tiny
+  (package
+    (name "perl-specio-library-path-tiny")
+    (version "0.05")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/D/DR/DROLSKY/Specio-Library-Path-Tiny-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0lbsqb3l5ra2k6481dkc7m1zk92fjpwnvgvql1k2rsyspjwhppv0"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-file-pushd perl-test-fatal))
+    (propagated-inputs (list perl-path-tiny perl-specio))
+    (home-page "https://metacpan.org/release/Specio-Library-Path-Tiny")
+    (synopsis "Types and coercions for Specio")
+    (description
+     "This library provides a set of @code{Path::Tiny} types and coercions for
+Specio.  These types can be used with @code{Moose}, @code{Moo},
+@code{Params::ValidationCompiler}, and other modules.")
+    (license license:asl2.0)))
+
 (define-public perl-spiffy
   (package
     (name "perl-spiffy")