diff mbox series

[bug#66801,v3,08/15] gnu: Add elixir-bunt.

Message ID b2da4496c5efd406e626bb5ddc7a62cbe66e45ec.1702056580.git.contact@phfrohring.com
State New
Headers show
Series None | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 5:31 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-bunt): New variable.

Change-Id: Ib84797c31d6ab40d59b87b040993dae9391ead6b
---
 gnu/packages/elixir-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index 348cba49a..2c042f11f 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -113,6 +113,25 @@  (define-public elixir-file-system
     (home-page "https://hexdocs.pm/file_system/")
     (license license:wtfpl2)))
 
+(define-public elixir-bunt
+  (package
+    (name "elixir-bunt")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "19bp6xh052ql3ha0v3r8999cvja5d2p6cph02mxphfaj4jsbyc53"))))
+    (build-system mix-build-system)
+    (arguments (list #:tests? #f)) ;There is no test/ in the source.
+    (synopsis "256 color ANSI coloring in the terminal")
+    (description "Bunt is an Elixir package that enables 256 color ANSI
+coloring in the terminal and allows users to alias colors to more semantic and
+application-specific names1.")
+    (home-page "https://hexdocs.pm/bunt/")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar