diff mbox series

[bug#66801,v3,09/15] gnu: Add elixir-inch-ex.

Message ID 3a6f72dfbc0fe8423fb9e9b2e95769184f998e06.1702056580.git.contact@phfrohring.com
State New
Headers show
Series None | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 5:31 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-inch-ex): New variable.

Change-Id: I6e98424528a0264a2587d28fcf065fa74eff0f1a
---
 gnu/packages/elixir-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index 2c042f11f..29d6857f4 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -132,6 +132,27 @@  (define-public elixir-bunt
     (home-page "https://hexdocs.pm/bunt/")
     (license license:expat)))
 
+(define-public elixir-inch-ex
+  (package
+    (name "elixir-inch-ex")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1a4rjcy3hn5pc40si1d1y7qg0b0mnxx6pw825la67ky8r9gfrl4n"))))
+    (build-system mix-build-system)
+    (arguments (list #:tests? #f)) ;No test/ in the sources.
+    (propagated-inputs (list elixir-bunt elixir-jason))
+    (synopsis
+     "Suggest enhancements for inline documentation")
+    (description
+     "This package provides a Mix task that gives you hints where to improve your
+inline docs.")
+    (home-page "https://hex.pm/packages/inch_ex")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar