diff mbox series

[bug#66801,v3,05/15] gnu: Add elixir-makeup.

Message ID 39dc11c378ab42b704fa4cbf0e851fa6f97b76f1.1702056580.git.contact@phfrohring.com
State New
Headers show
Series None | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 5:31 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-makeup): New variable.

Change-Id: I21fe9ffddb4c95a2c67b74340b1105c2a54d3c82
---
 gnu/packages/elixir-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index c2ff4d7bb..46565c168 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -50,6 +50,26 @@  (define-public elixir-nimble-parsec
     (home-page "https://hexdocs.pm/nimble_parsec/")
     (license license:asl2.0)))
 
+(define-public elixir-makeup
+  (package
+    (name "elixir-makeup")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "19jpprryixi452jwhws3bbks6ki3wni9kgzah3srg22a3x8fsi8a"))))
+    (build-system mix-build-system)
+    (propagated-inputs (list elixir-nimble-parsec))
+    (arguments (list #:tests? #f)) ;No test/ directory in the source tarball.
+    (synopsis "Syntax highlighter for source code")
+    (description
+     "Makeup is a generic syntax highlighter in the style of Pygments suitable for use in code hosting,
+forums, wikis or other applications that need to prettify source code.")
+    (home-page "https://hexdocs.pm/makeup/")
+    (license license:bsd-2)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar