[bug#75980,rust-team,100/106] gnu: rust-malloc-buf-0.0: Rename to rust-malloc-buf-0.0.6.

Message ID b1bb67efec8539956fa297b88e6c3f4ef51912f7.1738357375.git.herman@rimm.ee
State New
Headers
Series Add cargo-development-inputs. |

Commit Message

Herman Rimm Jan. 31, 2025, 9:12 p.m. UTC
  * gnu/packages/crates-apple.scm (rust-objc-0.2): Replace
rust-malloc-buf-0.0 with 0.0.6.
* gnu/packages/crates-io.scm (rust-malloc-buf-0.0): Rename to
rust-malloc-buf-0.0.6.

Change-Id: Ie8eea0b34dd35c52c374b04d6d0e3af6ebd8106d
---
 gnu/packages/crates-apple.scm | 2 +-
 gnu/packages/crates-io.scm    | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index 1c3c941209d..007536627d8 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -976,7 +976,7 @@  (define-public rust-objc-0.2
     (arguments
      `(#:tests? #f  ; Tests require gcc-objc.
        #:cargo-inputs
-       (("rust-malloc-buf" ,rust-malloc-buf-0.0)
+       (("rust-malloc-buf" ,rust-malloc-buf-0.0.6)
         ("rust-objc-exception" ,rust-objc-exception-0.1))))
     (home-page "https://github.com/SSheldon/rust-objc")
     (synopsis "Objective-C Runtime bindings and wrapper for Rust")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 59feb573681..34f3a13800c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40683,7 +40683,7 @@  (define-public rust-malloc-buf-1
      "This package provides structs for handling malloc'd memory passed to Rust.")
     (license license:expat)))
 
-(define-public rust-malloc-buf-0.0
+(define-public rust-malloc-buf-0.0.6
   (package
     (inherit rust-malloc-buf-1)
     (name "rust-malloc-buf")