[bug#75980,rust-team,093/106] gnu: rust-aes-soft-0.6: Replace cargo-inputs.

Message ID 2d57e1081a11295e8c605963c78bd01f478fe9ad.1738357375.git.herman@rimm.ee
State New
Headers
Series Add cargo-development-inputs. |

Commit Message

Herman Rimm Jan. 31, 2025, 9:10 p.m. UTC
  * gnu/packages/crates-crypto.scm (rust-aes-soft-0.6): Build.  Remove
rust-block-cipher-0.7, rust-byteorder-1.  Add rust-cipher-0.2.

Change-Id: I3d3bde139158af2e1a208c84f35626181c5b5550
---
 gnu/packages/crates-crypto.scm | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index cd3e97a5c9e..f855679ddad 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -378,13 +378,11 @@  (define-public rust-aes-soft-0.6
         (base32 "0wj0fi2pvmlw09yvb1aqf0mfkzrfxmjsf90finijh255ir4wf55y"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-block-cipher" ,rust-block-cipher-0.7)
-        ("rust-byteorder" ,rust-byteorder-1)
+     `(#:cargo-inputs
+       (("rust-cipher" ,rust-cipher-0.2)
         ("rust-opaque-debug" ,rust-opaque-debug-0.2))
        #:cargo-development-inputs
-       (("rust-block-cipher" ,rust-block-cipher-0.7))))
+       (("rust-cipher" ,rust-cipher-0.2))))
     (home-page "https://github.com/RustCrypto/block-ciphers")
     (synopsis "Bit-sliced implementation of AES (Rijndael) block ciphers")
     (description "This package provides a bit-sliced implementation of