[bug#75980,rust-team,068/106] gnu: rust-rspec-1: Add cargo-inputs.

Message ID 16b60768aa9a0fa2cb6b468a7f4db320ea641087.1738357374.git.herman@rimm.ee
State New
Headers
Series Add cargo-development-inputs. |

Commit Message

Herman Rimm Jan. 31, 2025, 9:10 p.m. UTC
  * gnu/packages/crates-io.scm (rust-rspec-1)[source]: Relax clippy
version requirement.
[arguments]: Add rust-clippy-0.0.302.
[description]: Change whitespace.
* gnu/local.mk (dist_patch_DATA): Unregister file.
* gnu/packages/patches/rust-rspec-1-remove-clippy.patch: Remove file.

Change-Id: I5f1e869aeedbf197f19f3a0c7ba4ffdc6752209c
---
 gnu/local.mk                                     |  1 -
 gnu/packages/crates-io.scm                       |  9 ++++++---
 .../patches/rust-rspec-1-remove-clippy.patch     | 16 ----------------
 3 files changed, 6 insertions(+), 20 deletions(-)
 delete mode 100644 gnu/packages/patches/rust-rspec-1-remove-clippy.patch
  

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 1d15be886da..852d140dddf 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2197,7 +2197,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/rust-onenote-parser-for-clamav-parse-in-memory-buffer.patch	\
   %D%/packages/patches/rust-onenote-parser-for-clamav-property-type.patch	\
   %D%/packages/patches/rust-poem-1-fewer-deps.patch		\
-  %D%/packages/patches/rust-rspec-1-remove-clippy.patch	\
   %D%/packages/patches/rust-trash-2-update-windows.patch	\
   %D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch      \
   %D%/packages/patches/rw-igraph-0.10.patch			\
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6969a88d7e4..b5fbf3d73cb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -64477,7 +64477,9 @@  (define-public rust-rspec-1
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "02hfwxqjdc39ygnjysvn5qz343fahmwm16rxvxayh403d5y9wf49"))
-       (patches (search-patches "rust-rspec-1-remove-clippy.patch"))))
+       (modules '((guix build utils)))
+       (snippet #~(substitute* "Cargo.toml"
+                    (("\"0.0.153\"") "\"0.0\"")))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
@@ -64486,11 +64488,12 @@  (define-public rust-rspec-1
         ("rust-derive-builder" ,rust-derive-builder-0.9)
         ("rust-expectest" ,rust-expectest-0.12)
         ("rust-rayon" ,rust-rayon-1)
+        ("rust-clippy" ,rust-clippy-0.0.302)
         ("rust-time" ,rust-time-0.2))))
     (home-page "https://github.com/rust-rspec/rspec")
     (synopsis "Write Rspec-like tests with stable rust")
-    (description "This package helps writing Rspec-like tests with stable
-rust.")
+    (description
+     "This package helps writing Rspec-like tests with stable rust.")
     (license license:mpl2.0)))
 
 (define-public rust-rspec-1.0.0-beta.3
diff --git a/gnu/packages/patches/rust-rspec-1-remove-clippy.patch b/gnu/packages/patches/rust-rspec-1-remove-clippy.patch
deleted file mode 100644
index 46c994f7eec..00000000000
--- a/gnu/packages/patches/rust-rspec-1-remove-clippy.patch
+++ /dev/null
@@ -1,16 +0,0 @@ 
-Remove the dependency on clippy
-
-diff --git a/Cargo.toml b/Cargo.toml
-index 177cb80..7260c34 100644
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -39,9 +39,6 @@ version = "1.5"
- 
- [dependencies.time]
- version = "0.2"
--[build-dependencies.clippy]
--version = "0.0.153"
--optional = true
- 
- [features]
- default = []