[bug#74039,v2,3/5] gnu: Add python-bip32

Message ID b08d17ea1bfb60780babfaa26605a07a0ac67f86.1730063595.git.jesse@eisses.email
State New
Headers
Series [bug#74039,v2,1/5] gnu: Add python-ledgercomm |

Commit Message

iyzsong--- via Guix-patches via Oct. 27, 2024, 9:13 p.m. UTC
  From: Jesse Eisses <jesse@eisses.email>

Change-Id: I6f6e5a2048d9d124808bc53df9b493e61c0bcf07
---
 gnu/packages/finance.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
  

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index d96055601d..7e030daca9 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1149,6 +1149,29 @@  (define-public python-coincurve
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public python-bip32
+  (package
+    (name "python-bip32")
+    (version "3.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/darosior/python-bip32")
+                    (commit "1492d39312f1d9630363c292f6ab8beb8ceb16dd")))
+              (sha256
+               (base32
+                "048zwh1i11jbs6h8j8sqbl7kx5hcyhr7i61mq5snl3fpbr3hmid3"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-base58 python-coincurve))
+    (inputs (list gnu-make))
+    (arguments
+     (list #:tests? #f))
+    (home-page "https://github.com/darosior/python-bip32")
+    (synopsis "Minimalistic implementation of the BIP32 key derivation scheme")
+    (description
+     "Minimalistic implementation of the BIP32 key derivation scheme")
+    (license license:expat)))
+
 (define-public python-trezor
   (package
     (name "python-trezor")