[bug#74039,v2,4/5] gnu: Add python-ledger-bitcoin
Commit Message
From: Jesse Eisses <jesse@eisses.email>
Change-Id: Ic7956e573712e478981de47466468f339b153741
---
gnu/packages/finance.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -1172,6 +1172,30 @@ (define-public python-bip32
"Minimalistic implementation of the BIP32 key derivation scheme")
(license license:expat)))
+(define-public python-ledger-bitcoin
+ (package
+ (name "python-ledger-bitcoin")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ledger_bitcoin" version))
+ (sha256
+ (base32
+ "1drd15h4vsr5ysrmrrhh2lalzmnxkvi82x6a433yr8c2vf6zsynx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'sanity-check))))
+ (propagated-inputs (list python-bip32 python-coincurve python-ledgercomm
+ python-packaging python-typing-extensions))
+ (inputs (list python-ledgercomm))
+ (home-page "https://github.com/LedgerHQ/app-bitcoin-new")
+ (synopsis "Client for Ledger Nano Bitcoin application")
+ (description "Client for Ledger Nano Bitcoin application")
+ (license license:asl2.0)))
+
(define-public python-trezor
(package
(name "python-trezor")