[bug#74039,v2,1/5] gnu: Add python-ledgercomm

Message ID 42cbc6b9509ad22d60d78258413b304fc957c886.1730063595.git.jesse@eisses.email
State New
Headers
Series [bug#74039,v2,1/5] gnu: Add python-ledgercomm |

Commit Message

iyzsong--- via Guix-patches via Oct. 27, 2024, 9:13 p.m. UTC
  From: Jesse Eisses <jesse@eisses.email>

Change-Id: If62d5425c346063787da81a47907f5ee84a749ab
---
 gnu/packages/finance.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: 269e4034fcaf55324187efffb6ed5ba14d5e9286
  

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index d4594a1083..262380d13e 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -39,6 +39,7 @@ 
 ;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
 ;;; Copyright © 2024 Saku Laesvuori <saku@laesvuori.fi>
 ;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1100,6 +1101,24 @@  (define-public python-btchip-python
 Nano dongle.")
     (license license:asl2.0)))
 
+(define-public python-ledgercomm
+  (package
+    (name "python-ledgercomm")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "ledgercomm" version))
+              (sha256
+               (base32
+                "019f13h59yxxhyhvi5xz8b20pfhazbvn9sgx5x98mp2shj6cks8y"))))
+    (arguments
+     (list #:tests? #f))
+    (build-system pyproject-build-system)
+    (home-page "https://github.com/LedgerHQ/ledgercomm")
+    (synopsis "Library to communicate with Ledger Nano S/X and Speculos")
+    (description "Library to communicate with Ledger Nano S/X and Speculos")
+    (license license:expat)))
+
 (define-public python-trezor
   (package
     (name "python-trezor")