diff mbox series

[bug#66801,3/5] gnu: Add erlang-lager.

Message ID a97b7b5d5fb4ea5560816c1937466d1379ede6ba.1699434044.git.phfrohring@deeplinks.com
State New
Headers show
Series build Erlang packages with dependencies | expand

Commit Message

Pierre-Henry Fröhring Nov. 8, 2023, 9:22 a.m. UTC
Change-Id: Iee1182644d57b7cca08afc6078102cc2409ede18
---
 gnu/packages/erlang-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 082af121..4ed8099f 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -48,6 +48,25 @@  (define-public erlang-goldrush
     (home-page "https://hex.pm/packages/goldrush")
     (license license:isc)))
 
+(define-public erlang-lager
+  (package
+    (name "erlang-lager")
+    (version "3.9.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "0a0c6kvc2jman62vrx2l3nx6xqn8s5l1glvf2mk7xjx8hyg4v43z"))))
+    (build-system rebar-build-system)
+    ;; XXX: tests fail.
+    (arguments (list #:tests? #f))
+    (propagated-inputs (list erlang-goldrush))
+    (synopsis "Erlang logging framework")
+    (description "Erlang logging framework")
+    (home-page "https://hexdocs.pm/lager/")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar