diff mbox series

[bug#66801,2/5] gnu: Add erlang-goldrush.

Message ID a93213f233d9d2f4106a40629cc5b7a3b7f23297.1699434044.git.phfrohring@deeplinks.com
State New
Headers show
Series build Erlang packages with dependencies | expand

Commit Message

Pierre-Henry Fröhring Nov. 8, 2023, 9:22 a.m. UTC
Change-Id: If978f3936375c9391f1655402a4504d708cfa67d
---
 gnu/packages/erlang-xyz.scm | 55 +++++++++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)
 create mode 100644 gnu/packages/erlang-xyz.scm
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
new file mode 100644
index 00000000..082af121
--- /dev/null
+++ b/gnu/packages/erlang-xyz.scm
@@ -0,0 +1,55 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Pierre-Henry Fröhring <phfrohring@deeplinks.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages erlang-xyz)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages)
+  #:use-module (guix build-system rebar)
+  #:use-module (guix download)
+  #:use-module (guix gexp)
+  #:use-module (guix git-download)
+  #:use-module (guix hg-download)
+  #:use-module (guix packages)
+  #:use-module (guix utils)
+  #:use-module (srfi srfi-1)
+  #:use-module (guix git-download)
+  #:use-module (gnu packages version-control)
+  #:use-module (srfi srfi-26))
+
+(define-public erlang-goldrush
+  (package
+    (name "erlang-goldrush")
+    (version "0.1.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1ssck5yr7rnrfwzm55pbyi1scgs1sl1xim75h5sj5czwrwl43jwr"))))
+    (build-system rebar-build-system)
+    (synopsis "Erlang event stream processor")
+    (description "Erlang event stream processor")
+    (home-page "https://hex.pm/packages/goldrush")
+    (license license:isc)))
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;