diff mbox series

[bug#66801,5/5] gnu: Add erlang-idna.

Message ID 0ac400beb2e94456ae681c6e2d6e09d5513053e6.1699434044.git.phfrohring@deeplinks.com
State New
Headers show
Series build Erlang packages with dependencies | expand

Commit Message

Pierre-Henry Fröhring Nov. 8, 2023, 9:22 a.m. UTC
Change-Id: Ie747409e9ef1f8a62ebefbc07131fef91e441a67
---
 gnu/packages/erlang-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 0c614542..fb614505 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -83,6 +83,27 @@  (define-public erlang-unicode-util-compat
     (home-page "https://hex.pm/packages/unicode_util_compat")
     (license license:asl2.0)))
 
+(define-public erlang-idna
+  (package
+    (name "erlang-idna")
+    (version "6.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1sjcjibl34sprpf1dgdmzfww24xlyy34lpj7mhcys4j4i6vnwdwj"))))
+    (build-system rebar-build-system)
+    (propagated-inputs (list erlang-unicode-util-compat))
+    (synopsis
+     "Erlang Internationalized Domain Names in Applications (IDNA) protocol")
+    (description
+     "Library to register and look up IDNs in a way
+   that does not require changes to the DNS itself.  IDNA is only meant for
+processing domain names, not free text. See: RFC 5891.")
+    (home-page "https://hexdocs.pm/idna/")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar