diff mbox series

[bug#70827,6/9] gnu: Add r-mlr3mbo.

Message ID a1621e9fc3303207d2b0ca2f5bdb651e07e73cd3.1715130172.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#70827,1/9] gnu: Add r-mlr3cluster. | expand

Commit Message

Mădălin Ionel Patrașcu May 8, 2024, 1:02 a.m. UTC
* gnu/packages/cran.scm (r-mlr3mbo): New variable.

Change-Id: I23d7af239f7ab55599faf99d5136621cc45c973f
---
 gnu/packages/cran.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 399225445b..d1fc4cbb2f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37887,6 +37887,42 @@  (define-public r-mlr3hyperband
 black-box optimization in bbotk.")
     (license license:lgpl3)))
 
+(define-public r-mlr3mbo
+  (package
+    (name "r-mlr3mbo")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mlr3mbo" version))
+       (sha256
+        (base32 "0jdj5dx6jb7n0g950h0j8jhafdj5mcalv5vxfiyf07myr6mjipri"))))
+    (properties `((upstream-name . "mlr3mbo")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bbotk
+                             r-checkmate
+                             r-data-table
+                             r-lgr
+                             r-mlr3
+                             r-mlr3misc
+                             r-mlr3tuning
+                             r-paradox
+                             r-r6
+                             r-spacefillr))
+    (native-inputs (list r-knitr))
+    (home-page "https://mlr3mbo.mlr-org.com")
+    (synopsis "Flexible Bayesian optimization")
+    (description
+     "This package provides a flexible approach to Bayesian optimization / model
+based optimization building on the bbotk package.  The mlr3mbo is a toolbox
+providing both ready-to-use optimization algorithms as well as their fundamental
+building blocks allowing for straightforward implementation of custom algorithms.
+Single- and multi-objective optimization is supported as well as mixed continuous,
+categorical and conditional search spaces.  Moreover, using mlr3mbo for
+hyperparameter optimization of machine learning models within the mlr3 ecosystem
+is straightforward via mlr3tuning.")
+    (license license:lgpl3)))
+
 (define-public r-mlr3measures
   (package
     (name "r-mlr3measures")