diff mbox series

[bug#70827,5/9] gnu: Add r-mlr3hyperband.

Message ID 4be2d0771f4fd6410a8510a2ff71ba1af0d2bf19.1715130172.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#70827,1/9] gnu: Add r-mlr3cluster. | expand

Commit Message

Mădălin Ionel Patrașcu May 8, 2024, 1:02 a.m. UTC
* gnu/packages/cran.scm (r-mlr3hyperband): New variable.

Change-Id: I3e7a829da1f7687ef0bb201f6333bdd519cfa025
---
 gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 459ad63c23..399225445b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37856,6 +37856,37 @@  (define-public r-mlr3fselect
 the performance of optimized feature sets with nested resampling.")
     (license license:lgpl3)))
 
+(define-public r-mlr3hyperband
+  (package
+    (name "r-mlr3hyperband")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mlr3hyperband" version))
+       (sha256
+        (base32 "1x6vfhadxlb4c9q61d5qv957mkyfwdwchzbg3flfd0j28b4bck1p"))))
+    (properties `((upstream-name . "mlr3hyperband")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bbotk
+                             r-checkmate
+                             r-data-table
+                             r-lgr
+                             r-mlr3
+                             r-mlr3misc
+                             r-mlr3tuning
+                             r-paradox
+                             r-r6))
+    (home-page "https://mlr3hyperband.mlr-org.com")
+    (synopsis "Hyperband for mlr3")
+    (description
+     "This package implements a successive halving and hyperband optimization
+algorithm for the mlr3 ecosystem.  The implementation in mlr3hyperband features
+improved scheduling and parallelizes the evaluation of configurations.  The package
+includes tuners for hyperparameter optimization in mlr3tuning and optimizers for
+black-box optimization in bbotk.")
+    (license license:lgpl3)))
+
 (define-public r-mlr3measures
   (package
     (name "r-mlr3measures")