diff mbox series

[bug#70827,8/9] gnu: Add r-mlr3viz.

Message ID 23421585e25455a72fb83e2e48bdbbed1efda140.1715130172.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#70827,1/9] gnu: Add r-mlr3cluster. | expand

Commit Message

Mădălin Ionel Patrașcu May 8, 2024, 1:02 a.m. UTC
* gnu/packages/cran.scm (r-mlr3viz): New variable.

Change-Id: Iedca442886ebeb09d26cfa44290192c582aeeef3
---
 gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6fcf0eb10d..74c741d754 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -38059,6 +38059,34 @@  (define-public r-mlr3tuningspaces
 work for a wide range of data sets.")
     (license license:lgpl3)))
 
+(define-public r-mlr3viz
+  (package
+    (name "r-mlr3viz")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mlr3viz" version))
+       (sha256
+        (base32 "1m2f54yqhk1bd4c30vd1z509yblz6y4i8qkwhg73aa1sflnsycvf"))))
+    (properties `((upstream-name . "mlr3viz")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-checkmate
+                             r-data-table
+                             r-ggplot2
+                             r-mlr3misc
+                             r-scales
+                             r-viridis))
+    (home-page "https://mlr3viz.mlr-org.com")
+    (synopsis "Visualizations for mlr3")
+    (description
+     "This package offers features plots for mlr3 objects such as tasks, learners,
+predictions, benchmark results, tuning instances and filters via the
+@code{autoplot()} generic of ggplot2.  The mlr3viz package draws plots with
+the viridis color palette and applies the minimal theme.  Visualizations include
+barplots, boxplots, histograms, ROC curves, and precision-recall curves.")
+    (license license:lgpl3)))
+
 (define-public r-paradox
   (package
     (name "r-paradox")