diff mbox series

[bug#62083,4/4] gnu: Add python-fluent-migrate.

Message ID a0562483-8a5e-87b0-9f1f-9047fd618fec@disroot.org
State New
Headers show
Series gnu: Add python-fluent-migrate. | expand

Commit Message

Adam Faiz March 9, 2023, 5:20 p.m. UTC
From 7be6e59c5231bb825c69c9ce48976bc49d2810ed Mon Sep 17 00:00:00 2001
Message-Id: <7be6e59c5231bb825c69c9ce48976bc49d2810ed.1678382249.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1678382249.git.adam.faiz@disroot.org>
References: <cover.1678382249.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 10 Mar 2023 00:19:27 +0800
Subject: [PATCH 4/4] gnu: Add python-fluent-migrate.

* gnu/packages/python-xyz.scm (python-fluent-migrate): New variable.
---
  gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
  1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 625c703aaf..5f695da802 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27650,6 +27650,36 @@  (define-public python-lazr-config
  validation.")
      (license license:lgpl3)))
  
+(define-public python-fluent-migrate
+  (package
+    (name "python-fluent-migrate")
+    (version "0.11")
+    (source
+     (origin
+       (method hg-fetch)
+       (uri (hg-reference
+             (url "https://hg.mozilla.org/l10n/fluent-migration/")
+             (changeset "fabfe61d6b73a7a0a7333a80f9eb066fee39588c")))
+       (file-name (hg-file-name name version))
+       (sha256
+          (base32
+           "18pxa40afgpmpf9r919scqdyf6xvnapxm7qzlhcls2ah3xx4y451"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list mercurial
+           python-hglib
+           python-mock))
+    (propagated-inputs
+     (list python-compare-locales
+         python-fluent-syntax
+         python-six))
+    (home-page "https://hg.mozilla.org/l10n/fluent-migration/")
+    (synopsis "Toolchain to migrate legacy translation to Fluent")
+    (description "@code{fluent.migrate} is a toolchain to migrate legacy translation
+to Fluent.  It can programmatically create Fluent files from existing content
+in both legacy and Fluent formats.")
+    (license license:asl2.0)))
+
  (define-public python-fluent-syntax
    (package
      (name "python-fluent-syntax")