diff mbox series

[bug#62083,3/4] gnu: Add python-compare-locales.

Message ID 6d159a1a-d9ab-c218-be39-33c5e0c188ce@disroot.org
State New
Headers show
Series gnu: Add python-fluent-migrate. | expand

Commit Message

Adam Faiz March 9, 2023, 5:18 p.m. UTC
From 4a3c42b3b8756a561a084d1f4265c71a6751dae5 Mon Sep 17 00:00:00 2001
Message-Id: <4a3c42b3b8756a561a084d1f4265c71a6751dae5.1678382249.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1678382249.git.adam.faiz@disroot.org>
References: <cover.1678382249.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 10 Mar 2023 00:11:38 +0800
Subject: [PATCH 3/4] gnu: Add python-compare-locales.

* gnu/packages/python-check.scm (python-compare-locales): New variable.
---
  gnu/packages/python-check.scm | 23 +++++++++++++++++++++++
  1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 41a6997190..dca5d07a54 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1715,6 +1715,29 @@  (define-public python-codacy-coverage
  analysing code quality.")
      (license license:expat)))
  
+(define-public python-compare-locales
+  (package
+    (name "python-compare-locales")
+    (version "8.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "compare-locales" version))
+              (sha256
+               (base32
+                "0m6qhf06qrhggsh5y325xbpssl5plwlhzmx3v93y3y38dkcm03a7"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-mock))
+    (propagated-inputs
+     (list python-fluent-syntax python-pytoml python-six))
+    (home-page "https://pypi.org/project/compare-locales/")
+    (synopsis "Lint Mozilla localizations")
+    (description
+     "Compare-locales finds missing strings, obsolete strings,
+errors on runtime errors without false positives, and warns
+on possible runtime errors.  It also includes l10n-merge functionality.")
+    (license license:mpl2.0)))
+
  (define-public python-httmock
    (package
      (name "python-httmock")