diff mbox series

[bug#62083,1/4] gnu: Add python-fluent-syntax.

Message ID 0f5b29fa-20f5-5885-fc29-c2fb0dcd9929@disroot.org
State New
Headers show
Series gnu: Add python-fluent-migrate. | expand

Commit Message

Adam Faiz March 9, 2023, 5:07 p.m. UTC
From ca7555bdf0939dff37ea698fb918601cc6d59a49 Mon Sep 17 00:00:00 2001
Message-Id: <ca7555bdf0939dff37ea698fb918601cc6d59a49.1678381163.git.adam.faiz@disroot.org>
In-Reply-To: <cover.1678381163.git.adam.faiz@disroot.org>
References: <cover.1678381163.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 23:38:43 +0800
Subject: [PATCH 1/4] gnu: Add python-fluent-syntax.

* gnu/packages/python-xyz.scm (python-fluent-syntax): New variable.
---
  gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
  1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92ea561737..625c703aaf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27650,6 +27650,35 @@  (define-public python-lazr-config
  validation.")
      (license license:lgpl3)))
  
+(define-public python-fluent-syntax
+  (package
+    (name "python-fluent-syntax")
+    (version "0.18.1")
+    (source
+     (origin
+       ;; Tests not included in release.
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/projectfluent/python-fluent")
+              (commit (string-append "fluent.syntax@" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "06a88fyhqvmhpp1wf7ghcmpzg92s8wgpb1bbi4y09ixva5r9dgwg"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-six))
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'build 'chdir
+               (lambda _
+                 (chdir "fluent.syntax"))))))
+    (home-page "https://github.com/projectfluent/python-fluent")
+    (synopsis "Localization library for expressive translations")
+    (description "fluent.syntax provides the parser, serializer,
+and traversal utilities for the Fluent localization system.")
+    (license license:asl2.0)))
+
  (define-public python-flufl-bounce
    (package
      (name "python-flufl-bounce")