diff mbox series

[bug#61659,6/6] gnu: Add texlive-minted.

Message ID DM5PR03MB3163EE64DE1B91ED0C74E51BC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series gnu: Add texlive-minted. | expand

Commit Message

Morgan Smith Feb. 20, 2023, 5:36 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-minted): New variable.
---
 gnu/packages/tex.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 55f6952cc1..f63c5567fe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10032,6 +10032,33 @@  (define-public texlive-microtype
 the bundle.")
       (license license:lppl1.3c))))
 
+(define-public texlive-minted
+  (package
+    (inherit (simple-texlive-package
+              "texlive-minted"
+              (list "/doc/latex/minted/"
+                    "/source/latex/minted/"
+                    "/tex/latex/minted/")
+              (base32
+               "08pbhp4a9k8v49kji26206zzabp0nn0fz403l4w7gxajw9rj8icr")
+              #:trivial? #t))
+    (propagated-inputs (list python-pygments
+                             texlive-etoolbox
+                             texlive-fvextra
+                             texlive-generic-xstring
+                             texlive-latex-fancyvrb
+                             texlive-latex-float
+                             texlive-latex-framed
+                             texlive-latex-ifplatform
+                             texlive-latex-newfloat
+                             texlive-lineno))
+    (home-page "https://ctan.org/pkg/minted")
+    (synopsis "Highlighted source code for LaTeX")
+    (description "Facilitates expressive syntax highlighting in LaTeX using
+the Pygments library.  The package also provides options to customize the
+highlighted source code output using fancyvrb and fvextra.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-caption
   (let ((template (simple-texlive-package
                    "texlive-caption"