diff mbox series

[bug#61659,5/6] gnu: Add texlive-fvextra.

Message ID DM5PR03MB3163877C9A5DA1B40D5B4A0BC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series gnu: Add texlive-minted. | expand

Commit Message

Morgan Smith Feb. 20, 2023, 5:36 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-fvextra): New variable.
---
 gnu/packages/tex.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d0d2e5db9..55f6952cc1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11170,6 +11170,24 @@  (define-public texlive-floatflt
 tables and figures to be set left/right or alternating on even/odd pages.")
     (license license:lppl1.3+)))
 
+(define-public texlive-fvextra
+  (package
+    (inherit (simple-texlive-package
+              "texlive-fvextra"
+              (list "/doc/latex/fvextra/"
+                    "/source/latex/fvextra/"
+                    "/tex/latex/fvextra/")
+              (base32
+               "0nawx1fh55yhqspy5jgss2qmwpqmikfrg7628smk931rph9nq0aa")
+              #:trivial? #t))
+    (home-page "https://ctan.org/macros/latex/contrib/fvextra")
+    (synopsis "Extensions and patches for fancyvrb")
+    (description
+     "Provides several extensions to fancyvrb, including automatic line
+breaking and improved math mode.  It also patches some fancyvrb internals.
+Parts of fvextra were originally developed as part of pythontex and minted.")
+    (license license:lppl1.3+)))
+
 (define-public bibtool
   (package
     (name "bibtool")