diff mbox series

[bug#61659,1/6] gnu: Add texlive-catchfile.

Message ID DM5PR03MB3163D52FEF51BE042E6AC33FC5A49@DM5PR03MB3163.namprd03.prod.outlook.com
State New
Headers show
Series gnu: Add texlive-minted. | expand

Commit Message

Morgan Smith Feb. 20, 2023, 5:36 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/tex.scm (texlive-catchfile): New variable.
---
 gnu/packages/tex.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dafed9d3c3..96c07de51b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5304,6 +5304,23 @@  (define-public texlive-carlisle
 in LaTeX documents; a jiffy to create slashed characters for physicists.")
     (license license:lppl)))
 
+(define-public texlive-catchfile
+  (package
+    (inherit (simple-texlive-package
+              "texlive-catchfile"
+              (list "/doc/latex/catchfile/"
+                    "/source/latex/catchfile/"
+                    "/tex/generic/catchfile/")
+              (base32
+               "1dpxy64hs0bjp8d2dmikflc995vazf7fi6z92w51fnj2fidgl8gx")
+              #:trivial? #t))
+    (home-page "https://ctan.org/macros/latex/contrib/catchfile")
+    (synopsis "Catch an external file into a macro")
+    (description
+     "Catches the contents of a file and puts it in a macro.  It requires
+e-TeX.  Both LaTeX and plain TeX are supported.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-doi
   (package
     (inherit (simple-texlive-package