diff mbox series

[bug#51587,1/3] gnu: Add python-sgmllib3k.

Message ID BYAPR05MB4023AC8025604B7969D393A7C58C9@BYAPR05MB4023.namprd05.prod.outlook.com
State Accepted
Headers show
Series Add rss2email. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Nov. 3, 2021, 4:37 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/python-xyz.scm (python-sgmllib3k): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Vinicius Monego Nov. 5, 2021, 3:35 p.m. UTC | #1
Hi,

I added this patch in 51314, and now I also noticed that it was
submitted even earlier in 50853. Maybe we should review that one first?

Em qua, 2021-11-03 às 12:37 -0400, Morgan.J.Smith@outlook.com escreveu:
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
> 
> * gnu/packages/python-xyz.scm (python-sgmllib3k): New variable.
> ---
>  gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-
> xyz.scm
> index 32d6b403d4..d2aca67aca 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -27643,3 +27643,26 @@ (define-public python-ijson
>       "Ijson is an iterative JSON parser with standard Python
> iterator
>  interfaces.")
>      (license license:bsd-3)))
> +
> +(define-public python-sgmllib3k
> +  (package
> +    (name "python-sgmllib3k")
> +    (version "1.0.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "sgmllib3k" version))
> +        (sha256
> +          (base32
> "1s8jm3dgqabgf8x96931scji679qkhvczlv3qld4qxpsicfgns3q"))))

Indentation nitpick here in the source.

> +    (build-system python-build-system)
> +    ;; Requires a test.html input that is not supplied
> +    (arguments
> +     `(#:tests? #f))
> +    (home-page "https://pypi.org/project/sgmllib3k/")
> +    ;; Actual homepage seems to be down
> +    ;; (home-page "https://hg.hardcoded.net/sgmllib")
> +    (synopsis "Python 3 port of sgmllib")
> +    (description "A quick, dirty, unmaintained port of sgmllib to
> Python 3.
> +It is used parse text files formatted in @acronym{SGML,Standard
> Generalized
> +Mark-up Language}.")

I think this description doesn't qualify as a full sentence.

> +    (license license:bsd-3)))
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32d6b403d4..d2aca67aca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27643,3 +27643,26 @@  (define-public python-ijson
      "Ijson is an iterative JSON parser with standard Python iterator
 interfaces.")
     (license license:bsd-3)))
+
+(define-public python-sgmllib3k
+  (package
+    (name "python-sgmllib3k")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "sgmllib3k" version))
+        (sha256
+          (base32 "1s8jm3dgqabgf8x96931scji679qkhvczlv3qld4qxpsicfgns3q"))))
+    (build-system python-build-system)
+    ;; Requires a test.html input that is not supplied
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://pypi.org/project/sgmllib3k/")
+    ;; Actual homepage seems to be down
+    ;; (home-page "https://hg.hardcoded.net/sgmllib")
+    (synopsis "Python 3 port of sgmllib")
+    (description "A quick, dirty, unmaintained port of sgmllib to Python 3.
+It is used parse text files formatted in @acronym{SGML,Standard Generalized
+Mark-up Language}.")
+    (license license:bsd-3)))