diff mbox series

[bug#51587,3/3] gnu: Add rss2email.

Message ID BYAPR05MB4023A0307A9DAFD2606605AFC58C9@BYAPR05MB4023.namprd05.prod.outlook.com
State Accepted
Headers show
Series Add rss2email. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Morgan Smith Nov. 3, 2021, 4:37 p.m. UTC
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/mail.scm (rss2email): New variable.
---
 gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

Vinicius Monego Nov. 5, 2021, 3:55 p.m. UTC | #1
Em qua, 2021-11-03 às 12:37 -0400, Morgan.J.Smith@outlook.com escreveu:
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
> 
> * gnu/packages/mail.scm (rss2email): New variable.
> ---
>  gnu/packages/mail.scm | 38 ++++++++++++++++++++++++++++++++++++++

Please add your copyright line in this file.

>  1 file changed, 38 insertions(+)
> 
> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
> index c5d8cf04ff..04d27d0337 100644
> --- a/gnu/packages/mail.scm
> +++ b/gnu/packages/mail.scm
> @@ -4614,3 +4614,41 @@ (define-public crm114
>  Bigrams, WINNOW, Correlation, KNN/Hyperspace, or Bit Entropy (or by
> other
>  means--it's all programmable).")
>      (license license:gpl3)))
> +
> +(define-public rss2email
> +  (package
> +    (name "rss2email")
> +    (version "3.13.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/rss2email/rss2email")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "0g1yr3v3ibdh2jqil64fbdbplx5m2yzxr893fqfkwcc5c7fbwl4d"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda* (#:key tests? inputs outputs #:allow-other-keys)

Inputs and outputs are not being used in the body.

> +             (when tests?
> +               (with-directory-excursion "test"
> +                 ;; Skip networking tests
> +                 (substitute* "test.py"
> +                   (("( *)class (:?TestSend|TestFetch).*" match
> indent)
> +                    (string-append indent
> "@unittest.skip(\"Networking stuff skipped\")\n"
> +                                   indent match)))
> +                 (invoke "python" "-m" "unittest"))))))))
> +    (propagated-inputs
> +     `(("python-feedparser" ,python-feedparser)
> +       ("python-html2text" ,python-html2text)))

Is this package used only as executable? Inputs can probably be normal
inputs here.

> +    (home-page "https://github.com/rss2email/rss2email")
> +    (synopsis "Converts RSS/Atom newsfeeds to email")
> +    (description "When run it fetches RSS/Atom newsfeeds, converts
> them into an email, and
> +emails them.")

Full sentence.

> +    ;; GPL version 2 or 3. NOT 2+.

Comments should also follow double spaces when starting a new sentence
in the same line.

> +    (license (list license:gpl2
> +                   license:gpl3))))
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index c5d8cf04ff..04d27d0337 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4614,3 +4614,41 @@  (define-public crm114
 Bigrams, WINNOW, Correlation, KNN/Hyperspace, or Bit Entropy (or by other
 means--it's all programmable).")
     (license license:gpl3)))
+
+(define-public rss2email
+  (package
+    (name "rss2email")
+    (version "3.13.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/rss2email/rss2email")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0g1yr3v3ibdh2jqil64fbdbplx5m2yzxr893fqfkwcc5c7fbwl4d"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (with-directory-excursion "test"
+                 ;; Skip networking tests
+                 (substitute* "test.py"
+                   (("( *)class (:?TestSend|TestFetch).*" match indent)
+                    (string-append indent "@unittest.skip(\"Networking stuff skipped\")\n"
+                                   indent match)))
+                 (invoke "python" "-m" "unittest"))))))))
+    (propagated-inputs
+     `(("python-feedparser" ,python-feedparser)
+       ("python-html2text" ,python-html2text)))
+    (home-page "https://github.com/rss2email/rss2email")
+    (synopsis "Converts RSS/Atom newsfeeds to email")
+    (description "When run it fetches RSS/Atom newsfeeds, converts them into an email, and
+emails them.")
+    ;; GPL version 2 or 3. NOT 2+.
+    (license (list license:gpl2
+                   license:gpl3))))