diff mbox series

[bug#51432,4/4] gnu: Add flask-combo-jsonapi

Message ID 9fbd923745c213a3e86cb9701aa8af9e@selfhosted.xyz
State Accepted
Headers show
Series gnu: Add flask-combo-jsonapi | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

david larsson Oct. 27, 2021, 11:02 a.m. UTC
On 2021-10-27 12:52, david larsson wrote:
> Hi!
> This patch series is to add python-flask-combo-jsonapi and necessary
> dependencies.
> 
> Best regards,
> David

Finally, adds the package flask-combo-jsonapi.
diff mbox series

Patch

From 6fbec5bdd04c5661b805cf958f36478cfc7883f8 Mon Sep 17 00:00:00 2001
From: David Larsson <david.larsson@selfhosted.xyz>
Date: Wed, 27 Oct 2021 09:04:40 +0200
Subject: [PATCH 4/4] gnu: Add flask-combo-jsonapi.

* gnu/packages/python-web.scm (python-flask-combo-jsonapi): New variable.
---
 gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a38ed5c268..0d173aa09d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6249,3 +6249,37 @@  communicate with Microsoft Azure Storage services.")
 comments, or tags from HTML snippets, extract base url from HTML snippets,
 translate entities on HTML strings, among other things.")
     (license license:bsd-3)))
+
+(define-public python-flask-combo-jsonapi
+  (package
+    (name "python-flask-combo-jsonapi")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/AdCombo/flask-combo-jsonapi/archive/"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1sygp9rx7zb1dbjxhb11mpas0c0px4md7mvi9pwbh1s1rr1glm3m"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-flask" ,python-flask)
+        ("python-marshmallow" ,python-marshmallow-3.2)
+        ("python-marshmallow-jsonapi" ,python-marshmallow-jsonapi)
+        ("python-simplejson" ,python-simplejson)
+        ("python-sqlalchemy" ,python-sqlalchemy-1.3)
+        ("python-apispec" ,python-apispec)
+        ("python-simplejson" ,python-simplejson)
+        ("python-six" ,python-six)))
+    (native-inputs `(("python-coverage" ,python-coverage)
+                     ("python-coveralls" ,python-coveralls)
+                     ("python-pytest" ,python-pytest)
+                     ("python-pytest-runner" ,python-pytest-runner)))
+    (home-page "https://github.com/AdCombo/flask-combo-jsonapi")
+    (synopsis
+      "Flask extension to create REST web api according to JSON:API 1.0 specification with Flask, Marshmallow and data provider of your choice (SQLAlchemy, MongoDB, ...)")
+    (description
+      "Flask extension to create REST web api according to JSON:API 1.0 specification with Flask, Marshmallow and data provider of your choice (SQLAlchemy, MongoDB, ...)")
+    (license license:expat)))
-- 
2.31.0