diff mbox series

[bug#51432,2/4] gnu: Add marshmallow 3.2

Message ID 2cd5b21bb5273bf4f76414276c52ef13@selfhosted.xyz
State Accepted
Headers show
Series gnu: Add flask-combo-jsonapi | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

david larsson Oct. 27, 2021, 10:59 a.m. UTC
On 2021-10-27 12:52, david larsson wrote:
> Hi!
> This patch series is to add python-flask-combo-jsonapi and necessary
> dependencies.
> 
> Best regards,
> David

flask-combo-jsonapi needs a marshmallow that is at version 3.2.

Comments

Tobias Geerinckx-Rice Nov. 3, 2021, 2:30 p.m. UTC | #1
David,

Let's inherit the current python-marshmallow to avoid all this 
duplication:

+(define-public python-marshmallow-3.2
+  (package
+    (inherit python-marshmallow)
+    (version "3.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "marshmallow" version))
+       (sha256
+        (base32 
"1w18klwj0z9bqxj252qpj1hz8l46nl27sbc89rkajc7mln73wbws"))))))

If you're thinking, ‘wait a minute, what happens to my precious 
3.2 package if someone updates 3.9 in a weird way?’, well, you're 
right.  There are trade-offs to both.

Kind regards,

T G-R
diff mbox series

Patch

From 1467067415f940c410c95b7426a4d996173811cd Mon Sep 17 00:00:00 2001
From: David Larsson <david.larsson@selfhosted.xyz>
Date: Tue, 26 Oct 2021 19:44:35 +0200
Subject: [PATCH 2/4] gnu: Add marshmallow-3.2.

* gnu/packages/python-xyz.scm (python-marshmallow-3.2): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7b1e0efe2..9ca075e941 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19165,6 +19165,31 @@  Python datatypes.")
 complex datatypes to and from native Python datatypes.")
     (license license:expat)))
 
+(define-public python-marshmallow-3.2
+  (package
+    (name "python-marshmallow")
+    (version "3.2.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (pypi-uri "marshmallow" version))
+      (sha256
+       (base32
+        "1w18klwj0z9bqxj252qpj1hz8l46nl27sbc89rkajc7mln73wbws"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-dateutil" ,python-dateutil)
+       ("python-simplejson" ,python-simplejson)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytz" ,python-pytz)))
+    (home-page "https://github.com/marshmallow-code/marshmallow")
+    (synopsis "Convert complex datatypes to and from native
+Python datatypes")
+    (description "@code{marshmallow} provides a library for converting
+complex datatypes to and from native Python datatypes.")
+    (license license:expat))) ; MIT license
+
 (define-public python-apispec
   (package
     (name "python-apispec")
-- 
2.31.0