diff mbox series

[bug#51432,1/4] gnu: Add sqlalchemy-1.3

Message ID 98ab18241bb0ad6493ee361c723890a3@selfhosted.xyz
State Accepted
Headers show
Series gnu: Add flask-combo-jsonapi | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

david larsson Oct. 27, 2021, 10:56 a.m. UTC
On 2021-10-27 12:52, david larsson wrote:
> Hi!
> This patch series is to add python-flask-combo-jsonapi and necessary
> dependencies.
> 
> Best regards,
> David

Adds sqlalchemy-1.3 because flask-combo-jsonapi requires less than 
version 1.4.

Comments

Tobias Geerinckx-Rice Nov. 3, 2021, 1:27 p.m. UTC | #1
David,

Thanks!  I've pushed this series as 
52a7fba8fc78763967c15781ea9b9176d3b4cc26 et al.

> Subject: [PATCH 1/4] gnu: Add sqlalchemy-1.3.

Use the full package name here.  This applies to all patches in 
this series AFAICT.

> +    ;; (propagated-inputs
> +    ;;  `(("python-greenlet" ,python-greenlet)))

Why is this commented out?  Please add a comment in such cases (if 
you've verified that all dependents still work without it, or that 
it was added after 1.3.20).

Great news!  This whole package can instead be written as:

(define-public python-sqlalchemy-1.3
  (package
    (inherit python-sqlalchemy)
    (version "1.3.20")
    (source
     (origin
      (method url-fetch)
      (uri (pypi-uri "SQLAlchemy" version))
      (sha256
       (base32 "18b9am7bsqc4nj3d2h5r93i002apczxfvpfpcqbd6f0385zmrwnj"))))
    (propagated-inputs '())))

Kind regards,

T G-R
diff mbox series

Patch

From 5f49c1f0cb150199d485eb886e329bd05dc7383d Mon Sep 17 00:00:00 2001
From: David Larsson <david.larsson@selfhosted.xyz>
Date: Tue, 26 Oct 2021 19:39:37 +0200
Subject: [PATCH 1/4] gnu: Add sqlalchemy-1.3.

* gnu/packages/databases.scm (python-sqlalchemy-1.3): New variable.
---
 gnu/packages/databases.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0da6c2d1be..ef3b407ae4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3006,6 +3006,38 @@  designed for efficient and high-performing database access, adapted into a
 simple and Pythonic domain language.")
     (license license:x11)))
 
+(define-public python-sqlalchemy-1.3
+  (package
+    (name "python-sqlalchemy")
+    (version "1.3.20")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (pypi-uri "SQLAlchemy" version))
+      (sha256
+       (base32 "18b9am7bsqc4nj3d2h5r93i002apczxfvpfpcqbd6f0385zmrwnj"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-cython" ,python-cython) ; for C extensions
+       ("python-pytest" ,python-pytest)
+       ("python-mock"   ,python-mock))) ; for tests
+    ;; (propagated-inputs
+    ;;  `(("python-greenlet" ,python-greenlet)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _ (invoke "py.test"))))))
+    (home-page "https://www.sqlalchemy.org")
+    (synopsis "Database abstraction library")
+    (description
+     "SQLAlchemy is the Python SQL toolkit and Object Relational Mapper that
+gives application developers the full power and flexibility of SQL.  It
+provides a full suite of well known enterprise-level persistence patterns,
+designed for efficient and high-performing database access, adapted into a
+simple and Pythonic domain language.")
+    (license license:x11)))
+
 (define-public python2-sqlalchemy
   (package-with-python2 python-sqlalchemy))
 
-- 
2.31.0