diff mbox series

[bug#66177,3/5] gnu: python-django-4.2: Add --failfast to test-flags.

Message ID 9d912f8d395557daedbb0857fb8d30ed26d96aa8.1695551150.git.ngraves@ngraves.fr
State New
Headers show
Series Improve python-django-4.2 phases. | expand

Commit Message

Nicolas Graves Sept. 24, 2023, 10:25 a.m. UTC
* gnu/packages/django.scm (python-django-4.2): Add --failfast to test-flags.
---
 gnu/packages/django.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 0e85860176..a6ef52870e 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -70,7 +70,9 @@  (define-public python-django-4.2
        (list
         ;; By default tests run in parallel, which may cause various race
         ;; conditions.  Run sequentially for consistent results.
-        "--parallel=1")
+        "--parallel=1"
+        ;; The test suite fails as soon as a single test fails.
+        "--failfast")
        #:phases
        (modify-phases %standard-phases
          (add-before 'check 'pre-check