diff mbox series

[bug#66177,1/5] gnu: python-django-4.2: Use test-flags argument.

Message ID 03a469274a39340a691e606612ee1f034098e412.1695551150.git.ngraves@ngraves.fr
State New
Headers show
Series Improve python-django-4.2 phases. | expand

Commit Message

Nicolas Graves Sept. 24, 2023, 10:25 a.m. UTC
* gnu/packages/django.scm (python-django-4.2): Use test-flags argument.
---
 gnu/packages/django.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)


base-commit: cc6fac3311f079c92c76a60192d93623eb094881
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4060819a35..f07433b10b 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -66,7 +66,12 @@  (define-public python-django-4.2
                 "1ha6c5j3pizbsfzw37r52lvdz8z5lblq4iwa99mpkdzz92aiqp2y"))))
     (build-system python-build-system)
     (arguments
-     '(#:phases
+     '(#:test-flags
+       (list
+        ;; By default tests run in parallel, which may cause various race
+        ;; conditions.  Run sequentially for consistent results.
+        "--parallel=1")
+       #:phases
        (modify-phases %standard-phases
          (add-before 'check 'pre-check
            (lambda* (#:key inputs #:allow-other-keys)
@@ -85,16 +90,12 @@  (define-public python-django-4.2
                 (string-append "    @unittest.skipIf(True, 'Disabled by Guix')\n"
                                all)))))
          (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
+           (lambda* (#:key tests? test-flags #:allow-other-keys)
              (if tests?
                  (with-directory-excursion "tests"
                    ;; Tests expect PYTHONPATH to contain the root directory.
                    (setenv "PYTHONPATH" "..")
-                   (invoke "python" "runtests.py"
-                           ;; By default tests run in parallel, which may cause
-                           ;; various race conditions.  Run sequentially for
-                           ;; consistent results.
-                           "--parallel=1"))
+                   (apply invoke "python" "runtests.py" test-flags))
                  (format #t "test suite not run~%"))))
          ;; XXX: The 'wrap' phase adds native inputs as runtime dependencies,
          ;; see <https://bugs.gnu.org/25235>.  The django-admin script typically