diff mbox series

[bug#68067,7/8] gnu: Add go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird.

Message ID 8f9c818605c1899b71243f1ea53648a3a44bc721.1703711347.git.clement@lassieur.org
State New
Headers show
Series [bug#68067,1/8] gnu: Add go-gitlab-com-yawning-edwards25519-extra. | expand

Commit Message

Clément Lassieur Dec. 27, 2023, 9:12 p.m. UTC
* gnu/packages/golang.scm
(go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird):
New variable.

Change-Id: I03b390aa6e8644646622a4f5b89f25e6cd2f7bb0
---
 gnu/packages/golang.scm | 48 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cc9a36481f07..b74863c37083 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2570,6 +2570,54 @@  (define-public go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports
 Go.")
     (license license:cc0)))
 
+(define-public go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird
+  (package
+    (name "go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird")
+                    (commit (string-append "lyrebird-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0rifg5kgqp4c3b44j48fjmx00m00ai7fa4gaqrgphiqs1fc5586s"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:unpack-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
+       #:import-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird/cmd/lyrebird"
+       #:go ,go-1.20
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'substitutions
+           (lambda _
+             (with-directory-excursion
+                 "src/gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
+               (for-each
+                (lambda (file)
+                  (substitute* file
+                    (("edwards25519-extra.git") "edwards25519-extra")))
+                (list "common/ntor/ntor_test.go"
+                      "internal/x25519ell2/x25519ell2.go"))
+               (substitute* "internal/x25519ell2/x25519ell2.go"
+                 (("gitlab.com/yawning/obfs4.git")
+                  "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"))))))))
+    (propagated-inputs
+     (list go-filippo-io-edwards25519
+           go-github-com-dchest-siphash
+           go-github-com-refraction-networking-utls
+           go-gitlab-com-yawning-edwards25519-extra
+           go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-goptlib
+           go-golang-org-x-crypto
+           go-golang-org-x-net
+           go-golang-org-x-text))
+    (home-page "https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird")
+    (synopsis "Look-like nothing obfuscation protocol")
+    (description "This is a look-like nothing obfuscation protocol that
+incorporates ideas and concepts from Philipp Winter's ScrambleSuit protocol.")
+    (license (list license:bsd-2 license:bsd-3))))
+
 (define-public go-github-com-sevlyar-go-daemon
   (package
     (name "go-github-com-sevlyar-go-daemon")