diff mbox series

[bug#68067,4/8] gnu: Add go-github-com-bwesterb-go-ristretto.

Message ID 7eeb90ffd47d3e1d932457d777303d9919fcdcde.1703711347.git.clement@lassieur.org
State New
Headers show
Series [bug#68067,1/8] gnu: Add go-gitlab-com-yawning-edwards25519-extra. | expand

Commit Message

Clément Lassieur Dec. 27, 2023, 9:12 p.m. UTC
* gnu/packages/golang.scm (go-github-com-bwesterb-go-ristretto): New variable.

Change-Id: Icbe3bc2808776d6451ad154653245439173424d5
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e1f0b7c4a07b..ae62ab4fedf3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10831,6 +10831,29 @@  (define-public go-gitlab-com-yawning-edwards25519-extra
 @@url{https://filippo.io/edwards25519,edwards25519} package as much as possible.")
       (license license:bsd-3))))
 
+(define-public go-github-com-bwesterb-go-ristretto
+  (package
+    (name "go-github-com-bwesterb-go-ristretto")
+    (version "1.2.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/bwesterb/go-ristretto")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0h508v790wk6g8jq0gh18296xl87vmgc4fhwnac7mk6i5g3mz6v4"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:unpack-path "github.com/bwesterb/go-ristretto"
+       #:import-path "github.com/bwesterb/go-ristretto/edwards25519"))
+    (home-page "https://github.com/bwesterb/go-ristretto")
+    (synopsis "operations on the Ristretto prime-order group")
+    (description "This is a pure Go implementation of the group operations on
+the Ristretto prime-order group built from Edwards25519.")
+    (license license:expat)))
+
 (define-public go-github-com-rogpeppe-go-internal
   (package
     (name "go-github-com-rogpeppe-go-internal")