diff mbox series

[bug#68067,5/8] gnu: Add go-github-com-cloudflare-circl.

Message ID 2a642369225ec26c2525b0b4aeedfe095b96372f.1703711347.git.clement@lassieur.org
State New
Headers show
Series [bug#68067,1/8] gnu: Add go-gitlab-com-yawning-edwards25519-extra. | expand

Commit Message

Clément Lassieur Dec. 27, 2023, 9:12 p.m. UTC
* gnu/packages/golang.scm (go-github-com-cloudflare-circl): New variable.

Change-Id: Iec8076faa4e14d31311424dbb999fbf8565a49e8
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ae62ab4fedf3..bc47e3184b50 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6332,6 +6332,35 @@  (define-public go-github-com-libp2p-go-libp2p-crypto
       (description "Various cryptographic utilities used by IPFS")
       (license license:expat))))
 
+(define-public go-github-com-cloudflare-circl
+  (package
+    (name "go-github-com-cloudflare-circl")
+    (version "1.3.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/cloudflare/circl")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "05hk5svprcjrj6k4mg4kd732pnb658llqv04z6xrcl5v77jda2kd"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/cloudflare/circl"))
+    (propagated-inputs
+     (list go-github-com-bwesterb-go-ristretto
+           go-golang-org-x-crypto
+           go-golang-org-x-sys))
+    (home-page "https://blog.cloudflare.com/introducing-circl")
+    (synopsis "Cloudflare Interoperable Reusable Cryptographic Library")
+    (description "CIRCL (Cloudflare Interoperable, Reusable Cryptographic
+Library) is a collection of cryptographic primitives written in Go.  The goal
+of this library is to be used as a tool for experimental deployment of
+cryptographic algorithms targeting Post-Quantum (PQ) and Elliptic Curve
+Cryptography (ECC).")
+    (license license:bsd-3)))
+
 (define-public go-github-com-mr-tron-base58
   (let ((commit "d724c80ecac7b49e4e562d58b2b4f4ee4ed8c312")
         (revision "0"))