diff mbox series

[bug#69736,1/7] gnu: Add python-typing-extensions-4.10.

Message ID 8df7adb0e828150216c4356f360c75646f465a29.1710180345.git.arunisaac@systemreboot.net
State New
Headers show
Series Add toil | expand

Commit Message

Arun Isaac March 11, 2024, 6:22 p.m. UTC
* gnu/packages/python-build.scm (python-typing-extensions-4.10): New variable.

Change-Id: I82d9538e76353b39cce082020a939e1a8fb7badc
---
 gnu/packages/python-build.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 2ea457cdba..adf26f7f8b 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2020, 2021, 2022, 2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
 
 ;;;
 ;;; This file is part of GNU Guix.
@@ -252,6 +253,18 @@  (define-public python-typing-extensions
 @end enumerate\n")
     (license license:psfl)))
 
+;; TODO: Remove this package once python-typing-extensions is updated.
+(define-public python-typing-extensions-4.10
+  (package
+    (inherit python-typing-extensions)
+    (version "4.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "typing_extensions" version))
+              (sha256
+               (base32
+                "1jxkj4pni8pdyrn79sq441lsp40xzw363n0qvfc6zfcgkv4dgaxh"))))))
+
 
 ;;;
 ;;; Python builder packages.