diff mbox series

[bug#69736,3/7] gnu: Add python-addict.

Message ID 4aaac246971a498c94a8ff50de693ff3ad2fb993.1710180345.git.arunisaac@systemreboot.net
State New
Headers show
Series Add toil | expand

Commit Message

Arun Isaac March 11, 2024, 6:22 p.m. UTC
* gnu/packages/python-xyz.scm (python-addict): New variable.

Change-Id: I1554d17495bf9337067422f2118f8b46e51abead
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ed9b1c9140..34b894a351 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23058,6 +23058,23 @@  (define-public python-attrdict3
 both as keys and as attributes.")
     (license license:expat)))
 
+(define-public python-addict
+  (package
+    (name "python-addict")
+    (version "2.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "addict" version))
+              (sha256
+               (base32
+                "1574sicy5ydx9pvva3lbx8qp56z9jbdwbj26aqgjhyh61q723cmk"))))
+    (build-system pyproject-build-system)
+    (home-page "https://github.com/mewwts/addict")
+    (synopsis "Python dictionary with attribute accessible values")
+    (description "@code{python-addict} provides dictionaries whose items can
+be get and set using both attribute and item syntax.")
+    (license license:expat)))
+
 (define-public python-attrs
   (package
     (name "python-attrs")