[bug#69736,2/7] gnu: Add python-pypubsub.
Commit Message
* gnu/packages/python-xyz.scm (python-pypubsub): New variable.
Change-Id: Id8f06bd592b6273cff282aa628f05503a67519b0
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -7768,6 +7768,32 @@ (define-public python-blinker
interested parties to subscribe to events, or \"signals\".")
(license license:expat)))
+(define-public python-pypubsub
+ (package
+ (name "python-pypubsub")
+ (version "4.0.3")
+ ;; There is no source tarball on PyPI.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/schollii/pypubsub")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02j74w28wzmdvxkk8i561ywjgizjifq3hgcl080yj0rvkd3wivlb"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/schollii/pypubsub")
+ (synopsis "Python publish-subscribe library")
+ (description "@code{python-pypubsub} provides a pure Python
+publish-subscribe API to facilitate event-based or message-based architecture
+in a single-process application. It is centered on the notion of a topic;
+senders publish messages of a given topic, and listeners subscribe to messages
+of a given topic, all inside the same process. The package also supports a
+variety of advanced features that facilitate debugging and maintaining topics
+and messages in larger desktop or server-based applications.")
+ (license license:bsd-2)))
+
(define-public pelican
(package
(name "pelican")