diff mbox series

[bug#67263,8/8] gnu: Add nats-server.

Message ID 8cd092123fd42e51fe17ce528f5e717146a81b19.1700330009.git.benjamin@uvy.fr
State New
Headers show
Series adding nats-server package | expand

Commit Message

Benjamin Nov. 18, 2023, 6:17 p.m. UTC
* gnu/packages/messaging.scm (nats-server): New variable.

Change-Id: Idb05684fae798b37d396279f136f11fce85e2e02
---
 gnu/packages/messaging.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1c5bc4bbd7..04474a1094 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2889,6 +2889,38 @@  (define-public mosquitto
     ;; Dual licensed.
     (license (list license:epl1.0 license:edl1.0))))
 
+(define-public nats-server
+  (package
+    (name "nats-server")
+    (version "2.10.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nats-io/nats-server")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07dcn6him4r1chsqr9p4i7fnbfw60gq29f4zmlyljf2c47i58rf9"))))
+    (build-system go-build-system)
+    (inputs (list go-github-com-klauspost-compress go-github-com-minio-highwayhash
+                  go-github-com-nats-io-jwt-v2 go-github-com-nats-io-nats-go
+                  go-github-com-nats-io-nkeys go-github-com-nats-io-nuid
+                  go-go-uber-org-automaxprocs go-golang-org-x-crypto
+                  go-golang-org-x-sys go-golang-org-x-time))
+    (arguments
+     (list #:go go-1.20 #:import-path "github.com/nats-io/nats-server" #:install-source? #f))
+    (home-page "https://github.com/nats-io/nats-server")
+    (synopsis "High performance message broker")
+    (description
+      "NATS is a simple, secure and performant communications system for digital
+      systems, services and devices. NATS is part of the Cloud Native Computing
+      Foundation (CNCF). NATS has over 40 client language implementations, and its
+      server can run on-premise, in the cloud, at the edge, and even on a Raspberry
+      Pi. NATS can secure and simplify design and operation of modern distributed
+      systems.")
+    (license license:asl2.0)))
+
 (define-public python-paho-mqtt
   (package
     (name "python-paho-mqtt")