mbox series

[bug#67263,0/8] adding nats-server package

Message ID cover.1700330009.git.benjamin@uvy.fr
Headers show
Series adding nats-server package | expand

Message

Benjamin Nov. 18, 2023, 6:14 p.m. UTC
Hello,

Here is a series of patch that is adding nats-server.
Nats [0] is a nice implementation in go of a message broker that is
memory efficient, really fast and also quite easy to package.

For now, I only added the server part. I am working on the command line
client but it is much more complicated to package (because of the number
of dependencies to add). I will add it in the future.

I added the nats-server in messaging.scm because I saw another message
broker there. The other possible location would be in golang.scm.

Best

Benjamin

[0] https://nats.io/


Benjamin (8):
  gnu: Add go-github-com-minio-highwayhash.
  gnu: Add go-github-com-prashantv-gostub.
  gnu: Add go-go-uber-org-automaxprocs.
  gnu: Add go-github-com-nats-io-nuid.
  gnu: Add go-github-com-nats-io-nkeys.
  gnu: Add go-github-com-nats-io-jwt-v2.
  gnu: Add go-github-com-nats-io-nats-go.
  gnu: Add nats-server.

 gnu/packages/golang-check.scm |  24 ++++++
 gnu/packages/golang.scm       | 148 ++++++++++++++++++++++++++++++++++
 gnu/packages/messaging.scm    |  32 ++++++++
 3 files changed, 204 insertions(+)


base-commit: 2ab5e449246f98b049888dde3c310f5b4a0a64a2

Comments

Sharlatan Hellseher Feb. 1, 2024, 7:55 p.m. UTC | #1
Hi,

Thank you for the patches!

I started the review process for this series.

NATS is in the same group as nsq, rabitmq, Kafka.
see <https://gcore.com/learning/nats-rabbitmq-nsq-kafka-comparison/>.
We may place it to high-availability module next to nsq.

golang.scm is a process of split into logical modules (golang-check,
 golang-crypto, golang-web, gokang-xyz). I would place
 packages which provides golag modules in any relevant.

Thanks,
Oleg
Sharlatan Hellseher Feb. 8, 2024, 9:55 p.m. UTC | #2
Hi Benjamin,

Your patches are finally reviewed, merged, sorted by golang-*.scm
modules and updated to the latest versions. I've slightly adjust some of
the to resolve lint warnings. nats-server is placed to high-availability
module next to nsq.

Looking foward for service(s) now =)

Pushed as ff61ca41d9..2d084f23a2 to master.

Regards,
Oleg