diff mbox series

[bug#67263,1/8] gnu: Add go-github-com-minio-highwayhash.

Message ID 23832dff8247bb34f3da1ceb04181bf90ffd5e4e.1700330009.git.benjamin@uvy.fr
State New
Headers show
Series adding nats-server package | expand

Commit Message

Benjamin Nov. 18, 2023, 6:17 p.m. UTC
* gnu/packages/golang.scm (go-github-com-minio-highwayhash): New variable.

Change-Id: Ib6aa8a38946841e840b17848b07434487f0435ef
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9c707e5414..00620690b9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6405,6 +6405,31 @@  (define-public go-github-com-minio-blake2b-simd
 increase approaching hashing speeds of 1GB/sec on a single core.")
       (license license:asl2.0))))
 
+(define-public go-github-com-minio-highwayhash
+  (package
+    (name "go-github-com-minio-highwayhash")
+    (version "1.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/minio/highwayhash")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1inrix7720273ccynxcyi7xsgc55cskxrw7gwn08qkmdj9xdxqai"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/minio/highwayhash"))
+    (propagated-inputs (list go-golang-org-x-sys))
+    (home-page "https://github.com/minio/highwayhash")
+    (synopsis "HighwayHash library for Go")
+    (description
+     "This package implements the pseudo-random-function (PRF) HighwayHash.
+HighwayHash is a fast hash function designed to defend hash-flooding attacks or
+to authenticate short-lived messages.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-spaolacci-murmur3
   (package
     (name "go-github-com-spaolacci-murmur3")