[bug#34265,8/9] gnu: ocaml-ppxlib: Update to 0.5.0.

Message ID 87va24wxva.fsf@gmail.com
State Accepted
Headers show
Series [bug#34265,1/9] gnu: dune: Update to 1.6.3. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Gabriel Hondet Jan. 31, 2019, 4:58 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppxlib): Update to 0.5.0.
---
 gnu/packages/ocaml.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8abbbab71..66a200520 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5177,7 +5177,7 @@  as part of the same ocaml-migrate-parsetree driver.")
 (define-public ocaml-ppxlib
   (package
     (name "ocaml-ppxlib")
-    (version "0.4.0")
+    (version "0.5.0")
     (home-page "https://github.com/ocaml-ppx/ppxlib")
     (source
      (origin
@@ -5188,7 +5188,7 @@  as part of the same ocaml-migrate-parsetree driver.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1nr4igf5m4prvigvv470dnhfdhdw0p6hz6zw8gnm5bzcv7s2lg5l"))))
+         "0d2nyp4mlx7m3vdvcdhs51x570vw30j645yfbwlhjpwdd8243fya"))))
     (build-system dune-build-system)
     (inputs
      `(("ocaml-base" ,ocaml-base)
@@ -5218,6 +5218,14 @@  as part of the same ocaml-migrate-parsetree driver.")
                  (("#use \"topfind\";;" all)
                   (string-append "#directory \"" findlib-libdir "\"\n"
                                  all))))
+             #t))
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (invoke "dune" "install"
+                       (string-append "--prefix=" out)
+                       (string-append "--libdir=" out
+                                      "/lib/ocaml/site-lib/")))
              #t)))))
     (synopsis
      "Base library and tools for ppx rewriters")