[bug#34265,9/9] gnu: Add ocaml-ppx-inline-test.

Message ID 87tvhowxls.fsf@gmail.com
State Accepted
Headers show
Series [bug#34265,1/9] gnu: dune: Update to 1.6.3. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Gabriel Hondet Jan. 31, 2019, 5:05 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-inline-test): New variable.
---
 gnu/packages/ocaml.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 66a200520..efbd8da18 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4705,6 +4705,47 @@  Dedukti files.")
 syntax checking on dedukti files.")
       (license license:cecill-b))))
 
+(define-public ocaml-ppx-inline-test
+  (package
+    (name "ocaml-ppx-inline-test")
+    (version "0.12-preview.120.18+252")
+    (home-page "https://github.com/janestreet/ppx_inline_test")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url (string-append home-page ".git"))
+             (commit "f594c2d98c9ef03009893cbddb1ad061e883bf7f")))
+       (sha256
+        (base32
+         "0b1n5xs429d93ysdq6vhg73rkh3r69fx78si8ls8jjgzg2svxald"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:tests? #f ;see home page README for further information
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (invoke "dune" "install"
+                       (string-append "--prefix=" out)
+                       (string-append "--libdir=" out
+                                      "/lib/ocaml/site-lib")))
+             #t)))))
+    (inputs
+     `(("ocaml-base" ,ocaml-base)
+       ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+       ("ocaml-compiler-libs" ,ocaml-compiler-libs)
+       ("ocaml-sexplib0" ,ocaml-sexplib0)
+       ("ocaml-stdio" ,ocaml-stdio)
+       ("ocaml-ppxlib" ,ocaml-ppxlib)))
+    (synopsis
+     "Syntax extension for writing in-line tests in ocaml code")
+    (description
+     "Part of the Jane Street's PPX rewriters collection.")
+    (license license:expat)))
+
 (define-public ocaml-biniou
  (package
    (name "ocaml-biniou")