[bug#34265,3/9] gnu: ocaml-ppx-derivers: Fix libdir install

Message ID 8736p8ycos.fsf@gmail.com
State Accepted
Headers show
Series [bug#34265,1/9] gnu: dune: Update to 1.6.3. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Gabriel Hondet Jan. 31, 2019, 4:28 p.m. UTC
---
 gnu/packages/ocaml.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5f95591d9..946360833 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5116,7 +5116,17 @@  a more consistent API.")
          "0bnhihl1w31as5w2czly1v3d6pbir9inmgsjg2cj6aaj9v1dzd85"))))
     (build-system dune-build-system)
     (arguments
-     '(#:tests? #f)) ;no tests
+     '(#:tests? #f ;no tests
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (invoke "dune" "install"
+                       (string-append "--prefix=" out)
+                       (string-append "--libdir=" out
+                                      "/lib/ocaml/site-lib/")))
+             #t)))))
     (synopsis "Shared @code{@@deriving} plugin registry")
     (description
      "Ppx_derivers is a tiny package whose sole purpose is to allow