diff mbox series

[bug#41134,2/2] gnu: Add libappindicator.

Message ID 87lfm3sz9v.fsf@ambrevar.xyz
State Accepted
Headers show
Series [bug#41134,1/2] gnu: Add libindicator. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Pierre Neidhardt May 8, 2020, 6:42 a.m. UTC
* gnu/packages/freedesktop.scm (libappindicator): New variable.
---
 gnu/packages/freedesktop.scm | 58 ++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)

Comments

Pierre Neidhardt May 8, 2020, 6:56 a.m. UTC | #1
I think it's the 4th time I send a patch with `git send-email' and
nothing shows up on debbugs (nor do I get an email notification if the
failure happened on the first email).

Anyone knows what's happening or how to fix it?
Nicolò Balzarotti May 11, 2020, 11:46 a.m. UTC | #2
Hi Pierre,

I packaged some time ago dbus-test-runner (libappindicator-12.10.1,
sligthly newer than yours, with all dependencies with all tests) but
never had the time to submit it.

If you want to take ownership of the patch and enable tests, here's the
file I was using
Thanks, Nicolò


Pierre Neidhardt <mail@ambrevar.xyz> writes:

> * gnu/packages/freedesktop.scm (libappindicator): New variable.
> ---
>  gnu/packages/freedesktop.scm | 58 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 58 insertions(+)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index d88c151df7..20e4024dfb 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -1801,3 +1801,61 @@ useful with system integration.")
>      (description "A set of symbols and convience functions that all indicators
>  would like to use.  Originally from the Ayatana indicators project.")
>      (license license:gpl3+)))
> +
> +(define-public libappindicator
> +  (package
> +    (name "libappindicator")
> +    (version "12.10.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://launchpad.net/libappindicator/"
> +             (version-major+minor version) "/" version
> +             "/+download/libappindicator-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "17xlqd60v0zllrxp8bgq3k5a1jkj0svkqn8rzllcyjh8k0gpr46m"))))
> +    (build-system gnu-build-system)
> +    (native-inputs
> +     `(("glib:bin" ,glib "bin")
> +       ("gobject-introspection" ,gobject-introspection)
> +       ("pkg-config" ,pkg-config)))
> +    (inputs
> +     `(("gtk+" ,gtk+)
> +       ("dbus-glib" ,dbus-glib)
> +       ("python" ,python-2)
> +       ("python2-pygtk" ,python2-pygtk)
> +       ("python2-pygobject" ,python2-pygobject)
> +       ("libdbusmenu" ,libdbusmenu)
> +       ("libindicator" ,libindicator)))
> +    (arguments
> +     `(#:configure-flags '("--with-gtk=3")
> +       #:make-flags '("CFLAGS=-Wno-error=deprecated-declarations")
> +       #:tests? #f              ; FIXME: Require the dbus-test-runner package.
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'fix-codegen-path
> +           (lambda _
> +             (substitute* "configure"
> +               (("PYGTK_CODEGEN=.*") "PYGTK_CODEGEN=pygtk-codegen-2.0\n"))
> +             #t))
> +         (add-after 'unpack 'disable-fail-on-error
> +           (lambda _
> +             (substitute* "src/Makefile.in"
> +               (("-Werror") ""))
> +             #t))
> +         (add-after 'unpack 'fix-test
> +           (lambda _
> +             (substitute* "tests/Makefile.in"
> +               (("/bin/bash") (which "bash"))
> +               (("/bin/sh") (which "sh")))
> +             (substitute* "docs/reference/Makefile.in"
> +               (("/bin/sh") (which "sh")))
> +             #t)))))
> +    (home-page "https://launchpad.net/libappindicator")
> +    (synopsis "Library to export a menu into the system tray")
> +    (description "A library to allow applications to export a menu, originally
> +into the Unity menu bar.  Based on KSNI, it also works in KDE and will
> +fallback to generic system tray support if none of those are available.")
> +    (license license:gpl3+)))
> -- 
> 2.25.1
> From a82ab4f66aed111c07358a238de3fc1e369799c0 Mon Sep 17 00:00:00 2001
> From: Pierre Neidhardt <mail@ambrevar.xyz>
> Date: Thu, 7 May 2020 11:24:09 +0200
> Subject: [PATCH 2/2] gnu: Add libappindicator.
>
> * gnu/packages/freedesktop.scm (libappindicator): New variable.
> ---
>  gnu/packages/freedesktop.scm | 58 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 58 insertions(+)
>
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index d88c151df7..20e4024dfb 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -1801,3 +1801,61 @@ useful with system integration.")
>      (description "A set of symbols and convience functions that all indicators
>  would like to use.  Originally from the Ayatana indicators project.")
>      (license license:gpl3+)))
> +
> +(define-public libappindicator
> +  (package
> +    (name "libappindicator")
> +    (version "12.10.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://launchpad.net/libappindicator/"
> +             (version-major+minor version) "/" version
> +             "/+download/libappindicator-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "17xlqd60v0zllrxp8bgq3k5a1jkj0svkqn8rzllcyjh8k0gpr46m"))))
> +    (build-system gnu-build-system)
> +    (native-inputs
> +     `(("glib:bin" ,glib "bin")
> +       ("gobject-introspection" ,gobject-introspection)
> +       ("pkg-config" ,pkg-config)))
> +    (inputs
> +     `(("gtk+" ,gtk+)
> +       ("dbus-glib" ,dbus-glib)
> +       ("python" ,python-2)
> +       ("python2-pygtk" ,python2-pygtk)
> +       ("python2-pygobject" ,python2-pygobject)
> +       ("libdbusmenu" ,libdbusmenu)
> +       ("libindicator" ,libindicator)))
> +    (arguments
> +     `(#:configure-flags '("--with-gtk=3")
> +       #:make-flags '("CFLAGS=-Wno-error=deprecated-declarations")
> +       #:tests? #f              ; FIXME: Require the dbus-test-runner package.
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'fix-codegen-path
> +           (lambda _
> +             (substitute* "configure"
> +               (("PYGTK_CODEGEN=.*") "PYGTK_CODEGEN=pygtk-codegen-2.0\n"))
> +             #t))
> +         (add-after 'unpack 'disable-fail-on-error
> +           (lambda _
> +             (substitute* "src/Makefile.in"
> +               (("-Werror") ""))
> +             #t))
> +         (add-after 'unpack 'fix-test
> +           (lambda _
> +             (substitute* "tests/Makefile.in"
> +               (("/bin/bash") (which "bash"))
> +               (("/bin/sh") (which "sh")))
> +             (substitute* "docs/reference/Makefile.in"
> +               (("/bin/sh") (which "sh")))
> +             #t)))))
> +    (home-page "https://launchpad.net/libappindicator")
> +    (synopsis "Library to export a menu into the system tray")
> +    (description "A library to allow applications to export a menu, originally
> +into the Unity menu bar.  Based on KSNI, it also works in KDE and will
> +fallback to generic system tray support if none of those are available.")
> +    (license license:gpl3+)))
> -- 
> 2.25.1
Pierre Neidhardt May 11, 2020, 12:14 p.m. UTC | #3
Thanks!

Actually you've got blueman here to, as in 41025@debbugs.gnu.org.
Raghav, Nicolò, what do you think?  Which is one is more complete?
Raghav Gururajan May 11, 2020, 2:18 p.m. UTC | #4
Hi Pierre!

> Actually you've got blueman here to, as in 41025@debbugs.gnu.org.
> Raghav, Nicolò, what do you think?  Which is one is more complete?

Pierre:
I'd say, let us go with dbus-test-runner from Nicolò's 4113#4;
libindicator+libappindicator from yours' 41143#0 and 4113#1; blueman
from my 41025#14.
So if you could update libindicator and libappindicator, by using
dbus-test-runner; I can update blueman to integrate them. Wdyt?

Nicolò:
Wdyt?

Regards,
RG.
Nicolò Balzarotti May 11, 2020, 3:07 p.m. UTC | #5
Raghav Gururajan <raghavgururajan@disroot.org> writes:

> Hi Pierre!
>
>> Actually you've got blueman here to, as in 41025@debbugs.gnu.org.
>> Raghav, Nicolò, what do you think?  Which is one is more complete?
>
> Pierre:
> I'd say, let us go with dbus-test-runner from Nicolò's 4113#4;
> libindicator+libappindicator from yours' 41143#0 and 4113#1; blueman
> from my 41025#14.
> So if you could update libindicator and libappindicator, by using
> dbus-test-runner; I can update blueman to integrate them. Wdyt?
>
> Nicolò:
> Wdyt?
>
Fine! But remember to also apply the this libpulse patch, as current
blueman fails to find pulseaudio

(substitute* "blueman/main/PulseAudioUtils.py"
       (("CDLL\\(\"libpulse")
	(string-append "CDLL(\""
		       (assoc-ref inputs "pulseaudio") "/lib/libpulse")))

> Regards,
> RG.
>
Thanks!

> -----BEGIN PGP PUBLIC KEY BLOCK-----
>
> mQENBF6yxWcBCAClEApjrOYs8fSzDl8GBwMFtUzF6VCOVrWaGun1vvPDvk4AFzbB
> 3ZV6+Jn8VfEuqh3OOvSJGHL2cJoR28Q5gVqeOwupyaMWVdEt6TmDrHISyxriF426
> KVaJnklfMjYwIi0l/7j8bs3pDRyyR6uFrY6sYL9t6HFvevtt7NwgWL1MAEVy6txK
> kriyrK1h+qc13wRRgVx3tzl7dNwYEDWd3yUDn+LESoDOlawJ7TQbO8d1K4FFHaqw
> yQ/SyaIfLBnMAz9Qd18MUWpDkktLh/9ujRfctouFx5BUr+uGgCHAWcII5D60lt86
> 7y5m6vp3Ua75TkVQrYTt7KSF/wm7NZ7L02fTABEBAAG0NFJhZ2hhdiBHdXJ1cmFq
> YW4gKFJHKSA8cmdAbWFpbC5yYWdoYXZndXJ1cmFqYW4ubmFtZT6JAVEEEwEIADsC
> GwMFCwkIBwIGFQoJCAsCBBYCAwECHgECF4AWIQQnQS80qpGN6kDSlCiubvMEbW97
> VwUCXrXjmQIZAQAKCRCubvMEbW97V32uCACYYyZoxs+lNb53hEB663VkZdF84C0j
> 0rCaUn0IKQSIy3fmHjFR1gmx5wXwWfOOtu7kjBgxGU/zWB1Nd3yTS+yZikd5IvF6
> mwXfXTrgtS4TPZy0t+bbrALYFyw9mBJbbyCfOgRB4/mMB+PGJk0pTqYIFwMtzFP/
> YSKWhVs+O2K2mPBZQninW0R9NGzbH1tDG5jABndtrvsQQhQN4iLkFl7x0NcaVUEO
> miBwprhk9S4rHjXdmafIxoy/nBhDgFNUuoxEwVrGSCmOT6J83gMfFyk96kGgG3Bq
> nPVuMX8C8AJRwpRXvRYkHX6tGyJEyIZJT48A0pE6yguIJf67fH+5nKcPtDNSYWdo
> YXYgR3VydXJhamFuIChSRykgPHJhZ2hhdmd1cnVyYWphbkBkaXNyb290Lm9yZz6J
> AU4EEwEIADgWIQQnQS80qpGN6kDSlCiubvMEbW97VwUCXrXj2wIbAwULCQgHAgYV
> CgkICwIEFgIDAQIeAQIXgAAKCRCubvMEbW97V71iB/9zYsGiX3KzqDv6+P63hND5
> n4FVkaVj/LoXcmYrgZnJ8pbcUpsWdXa5VqZ22qeT+7LFciJWOkqy0wHje0dEu9Bw
> CDZJ+17yqVmox0oV9DEeGzXqoxEzWYO4Idj04Os3052A9VEKnTcZzzIiU0gWQSwg
> Jvy4XRLooLeefbqAwPWRFS0ecnCofp8veDS1IZrkV6R/7G+hMtBSpnTHOOyjZ5Bk
> GsknhmPPEcDjYH79/664jWzidbddndqrKpIjqM57sYOTt50+qG3e4QrqvhGMI88E
> la1GbjHpTt9lBOHdonj4YjwX4qa1QjQxjxc7SU3tGPjkAGo49twgYBiGqfy9QqWd
> tDNSYWdoYXYgR3VydXJhamFuIChSRykgPHJhZ2hhdmd1cnVyYWphbkBzbm9weXRh
> Lm9yZz6JAU4EEwEIADgWIQQnQS80qpGN6kDSlCiubvMEbW97VwUCXrXj9wIbAwUL
> CQgHAgYVCgkICwIEFgIDAQIeAQIXgAAKCRCubvMEbW97V8mkB/98Jnh8OkkjRt8h
> 2x8vOynRzcx94pXDiSwHxRlCLSYaZ49NpGOSOqFyxPihxNUGfiq6B1WZnrKCsu78
> KZdTPScN1NqJCqwdm7RoV8yuS43G168nSvF3yT6RDssxbHSxCxDOqd+rQiqoXGuq
> gdOTfvYjg13b9wBSsoMkVjylmzP8x9BI9G0SuxG9X0Rqb7c6+my5aLTKiJek8c7P
> QTg7PzdYOBB+QGuhmDcfXfCer0xa5dPvZ3VEjjyIN/9bd8laVoK6c2jGea7gBo57
> hu/TTPi3hueGHtWoStGb7dPJKtY2Xrz2dv44bGLuLHaygHdr2YcHUTX8NC9383+y
> PAKxcKKouQENBF6yxWcBCADRjE1WgIkhraQG8UaPQBznNpIGrZALB/3o7czR9JrR
> sLRNIORodDikyOu/CiLWp87ZrpCnGZgZ4DwsL1BhjUGM1lsLEvpAbYucCdzhaK4P
> ibWLn/5/Q40gIZ2+4daYi/V4tHa1C5eaL1RUafyD5XZG090fKYHPVcAGtFVUT+fX
> bIBepz4aB48Xwaf13ANkEZ0XwdmzeAVQlWpSXpTxmEdKUsJH7RaZoWuBUWtC6ybX
> DHofjxttGrD4inBOLDRmU5h95Hh5E35OU7nbN5cub5aphCoO6mP86EtclkCY9I9+
> iaF9f62r6PoFMbM4oPNNeNGuWxdlVBES3CjvgqdJSOP/ABEBAAGJATYEGAEIACAW
> IQQnQS80qpGN6kDSlCiubvMEbW97VwUCXrLFZwIbDAAKCRCubvMEbW97V6kyB/wP
> c+9BywmXAH56Zbho+AD34t4WqnVO8b7a5DfXhyaD1e6cMctZbjUUfMYO2B5MHEP/
> ahHL0onDSL4Y0cOXEqclvRxpjhcome/ii391z1Iwu6QuaSDPgAFssg+RpcqmpB9c
> AXvEQvf/Lzcn2Z5m1eD1Lx6B72P8WR/g/wH4NSdooHSHm5EM84RQQuuUwChXjDSF
> kJGCDCo6uLvp5r97K3qr0b5bfFWKtFUqtuEhbNCSfnRJrjt/7O9tdtiSC9FxFEt6
> KBm/6eu/ETNjqXpS2XGUjxuryCK0BSsOvzVYw7TmNw6zT7UPofOFJxT1LWmcr0EM
> KRjY77Tc1P2JvjcLBZtE
> =cLME
> -----END PGP PUBLIC KEY BLOCK-----
Raghav Gururajan May 11, 2020, 3:10 p.m. UTC | #6
Hi Pierre!

>>> Actually you've got blueman here to, as in 41025@debbugs.gnu.org.
>>> Raghav, Nicolò, what do you think?  Which is one is more complete?
>>
>> Pierre:
>> I'd say, let us go with dbus-test-runner from Nicolò's 4113#4;
>> libindicator+libappindicator from yours' 41143#0 and 4113#1; blueman
>> from my 41025#14.
>> So if you could update libindicator and libappindicator, by using
>> dbus-test-runner; I can update blueman to integrate them. Wdyt?
>>
>> Nicolò:
>> Wdyt?
>>
> Fine! But remember to also apply the this libpulse patch, as current
> blueman fails to find pulseaudio
> 
> (substitute* "blueman/main/PulseAudioUtils.py"
>        (("CDLL\\(\"libpulse")
> 	(string-append "CDLL(\""
> 		       (assoc-ref inputs "pulseaudio") "/lib/libpulse")))
> 

It have already fixed libpulse issue in #41025#14. :-)

Regards,
RG.
Pierre Neidhardt May 14, 2020, 5:14 p.m. UTC | #7
I've pushed Nicolò's packages with minor changes:

- dbus-test-runner: 522b1148d1e78cd78a962e8046b3ed6ab34de8fa,
- libindicator: 5e2750fb9e3511b38a0b681e42fc4f528121a9d5
- libappindicator: c7b777130f31d313355562697d4f56480a93f477

Thanks!
diff mbox series

Patch

From a82ab4f66aed111c07358a238de3fc1e369799c0 Mon Sep 17 00:00:00 2001
From: Pierre Neidhardt <mail@ambrevar.xyz>
Date: Thu, 7 May 2020 11:24:09 +0200
Subject: [PATCH 2/2] gnu: Add libappindicator.

* gnu/packages/freedesktop.scm (libappindicator): New variable.
---
 gnu/packages/freedesktop.scm | 58 ++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d88c151df7..20e4024dfb 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1801,3 +1801,61 @@  useful with system integration.")
     (description "A set of symbols and convience functions that all indicators
 would like to use.  Originally from the Ayatana indicators project.")
     (license license:gpl3+)))
+
+(define-public libappindicator
+  (package
+    (name "libappindicator")
+    (version "12.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://launchpad.net/libappindicator/"
+             (version-major+minor version) "/" version
+             "/+download/libappindicator-" version ".tar.gz"))
+       (sha256
+        (base32
+         "17xlqd60v0zllrxp8bgq3k5a1jkj0svkqn8rzllcyjh8k0gpr46m"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("glib:bin" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("dbus-glib" ,dbus-glib)
+       ("python" ,python-2)
+       ("python2-pygtk" ,python2-pygtk)
+       ("python2-pygobject" ,python2-pygobject)
+       ("libdbusmenu" ,libdbusmenu)
+       ("libindicator" ,libindicator)))
+    (arguments
+     `(#:configure-flags '("--with-gtk=3")
+       #:make-flags '("CFLAGS=-Wno-error=deprecated-declarations")
+       #:tests? #f              ; FIXME: Require the dbus-test-runner package.
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-codegen-path
+           (lambda _
+             (substitute* "configure"
+               (("PYGTK_CODEGEN=.*") "PYGTK_CODEGEN=pygtk-codegen-2.0\n"))
+             #t))
+         (add-after 'unpack 'disable-fail-on-error
+           (lambda _
+             (substitute* "src/Makefile.in"
+               (("-Werror") ""))
+             #t))
+         (add-after 'unpack 'fix-test
+           (lambda _
+             (substitute* "tests/Makefile.in"
+               (("/bin/bash") (which "bash"))
+               (("/bin/sh") (which "sh")))
+             (substitute* "docs/reference/Makefile.in"
+               (("/bin/sh") (which "sh")))
+             #t)))))
+    (home-page "https://launchpad.net/libappindicator")
+    (synopsis "Library to export a menu into the system tray")
+    (description "A library to allow applications to export a menu, originally
+into the Unity menu bar.  Based on KSNI, it also works in KDE and will
+fallback to generic system tray support if none of those are available.")
+    (license license:gpl3+)))
-- 
2.25.1