diff mbox series

[bug#41134,1/2] gnu: Add libindicator.

Message ID 87o8qzszoa.fsf@ambrevar.xyz
State Accepted
Headers show
Series [bug#41134,1/2] gnu: Add libindicator. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Pierre Neidhardt May 8, 2020, 6:34 a.m. UTC
Sent this patch 24 hours ago with git-sendemail.  Nothing showed up.
Trying again manually.

Comments

Raghav Gururajan May 11, 2020, 11:38 a.m. UTC | #1
Hi Pierre!

Great job! Nice to have these for Blueman.

I tried packaging them while I was packaging blueman, but gave up as I got too many errors.

Regards,
RG.
diff mbox series

Patch

From 9520260642783cb3a16dac844221260ccb666c41 Mon Sep 17 00:00:00 2001
From: Pierre Neidhardt <mail@ambrevar.xyz>
Date: Thu, 7 May 2020 10:57:53 +0200
Subject: [PATCH 1/2] gnu: Add libindicator.

* gnu/packages/freedesktop.scm (libindicator): New variable.
---
 gnu/packages/freedesktop.scm | 41 ++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 75d0118f83..d88c151df7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1760,3 +1760,44 @@  that provides a graphical boot animation while the boot process happens in the
 background.  You are not supposed to install this on your own, it is only
 useful with system integration.")
     (license license:gpl2+)))
+
+(define-public libindicator
+  (package
+    (name "libindicator")
+    (version "12.10.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://launchpad.net/libindicator/"
+             (version-major+minor version) "/" version
+             "/+download/libindicator-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0zs4z7l9b57jldwz0ban77f3c2zq43ambd0dssf5qg9i216f9lmj"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("gobject-introspection" ,gobject-introspection)
+       ("glib:bin" ,glib "bin")))
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("glib" ,glib)))
+    (arguments
+     `(#:make-flags '("CFLAGS=-Wno-error=deprecated-declarations")
+       #:tests? #f              ; FIXME: Require the dbus-test-runner package.
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-typo
+           (lambda _
+             (substitute* "configure"
+               (("LIBINDICATOR_LIBS\\+\\=.......") "LIBINDICATOR_LIBS+=\" $LIBM\""))
+             (substitute* "tests/Makefile.in"
+               (("/bin/bash") (which "bash"))
+               (("/bin/sh") (which "sh")))
+             #t)))))
+    (home-page "https://launchpad.net/libindicator")
+    (synopsis "Convience functions for desktop indicators")
+    (description "A set of symbols and convience functions that all indicators
+would like to use.  Originally from the Ayatana indicators project.")
+    (license license:gpl3+)))
-- 
2.25.1