diff mbox series

[bug#34697,2/3] gnu: Add r-cyclocomp.

Message ID 874ky7mep5.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#34697,1/3] gnu: Add r-xmlparsedata. | expand

Commit Message

Nicolò Balzarotti Dec. 11, 2019, 8:19 a.m. UTC
* gnu/packages/cran.scm (r-cyclocomp): New variable.
---
 gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0a878dc340..9ff1dd3104 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14718,6 +14718,35 @@  tree, that one can search via @code{XPath}, and easier to manipulate in
 general.")
     (license license:expat)))
 
+(define-public r-cyclocomp
+  (package
+    (name "r-cyclocomp")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cyclocomp" version))
+       (sha256
+        (base32
+         "0gky3svk02wiajw7nfjh30684h3qxili4bvsab0m7b6cggw6bgyd"))))
+    (properties `((upstream-name . "cyclocomp")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-callr" ,r-callr)
+       ("r-crayon" ,r-crayon)
+       ("r-desc" ,r-desc)
+       ("r-remotes" ,r-remotes)
+       ("r-withr" ,r-withr)))
+    (home-page
+     "https://github.com/MangoTheCat/cyclocomp")
+    (synopsis "Cyclomatic Complexity of R Code")
+    (description
+     "Cyclomatic complexity is a software metric (measurement), used to
+indicate the complexity of a program.  It is a quantitative measure of the
+number of linearly independent paths through a program's source code.  It was
+developed by @cite{Thomas J. McCabe, Sr. in 1976}.")
+    (license license:expat)))
+
 (define-public r-sctransform
   (package
     (name "r-sctransform")