diff mbox series

[bug#34697,3/3] gnu: Add r-lintr.

Message ID 8736drmeog.fsf@guixSD.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#34697,1/3] gnu: Add r-xmlparsedata. | expand

Commit Message

Nicolò Balzarotti Dec. 11, 2019, 8:19 a.m. UTC
* gnu/packages/cran.scm (r-lintr): New variable.
---
 gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Ricardo Wurmus Dec. 11, 2019, 11:12 a.m. UTC | #1
Nicolò Balzarotti <anothersms@gmail.com> writes:

> * gnu/packages/cran.scm (r-lintr): New variable.

I pushed these three patches with minor changes.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9ff1dd3104..07432c2785 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14747,6 +14747,40 @@  number of linearly independent paths through a program's source code.  It was
 developed by @cite{Thomas J. McCabe, Sr. in 1976}.")
     (license license:expat)))
 
+(define-public r-lintr
+  (package
+    (name "r-lintr")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "lintr" version))
+       (sha256
+        (base32
+         "09gbci4v5n4gsfzminly8332fw7faxdi1kkyvpa10dydx02sjcwb"))))
+    (properties `((upstream-name . "lintr")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-codetools" ,r-codetools)
+       ("r-crayon" ,r-crayon)
+       ("r-cyclocomp" ,r-cyclocomp)
+       ("r-digest" ,r-digest)
+       ("r-httr" ,r-httr)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-knitr" ,r-knitr)
+       ("r-rex" ,r-rex)
+       ("r-rstudioapi" ,r-rstudioapi)
+       ("r-stringdist" ,r-stringdist)
+       ("r-testthat" ,r-testthat)
+       ("r-xml2" ,r-xml2)
+       ("r-xmlparsedata" ,r-xmlparsedata)))
+    (home-page "https://github.com/jimhester/lintr")
+    (synopsis "Linter for R Code")
+    (description "Checks adherence to a given style, syntax errors and
+possible semantic issues.  Supports on the fly checking of R code edited with
+@code{RStudio IDE}, @code{Emacs} and @code{Vim}.")
+    (license license:expat)))
+
 (define-public r-sctransform
   (package
     (name "r-sctransform")