diff mbox series

[bug#68171,1/2] gnu: python-h5py: Enable tests.

Message ID 874jfyinlb.fsf@troyfigiel.com
State New
Headers show
Series Enable tests for python-h5py | expand

Commit Message

Troy Figiel Dec. 30, 2023, 10:36 a.m. UTC
* gnu/packages/python-xyz.scm (python-h5py)[native-inputs]: Add python-ipython and python-pytest.

Change-Id: Ia1cae8bce802805c9d9b38a3bf515423f9b719b4
---
 gnu/packages/python-xyz.scm | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2afce6c667..b5384b7c42 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2257,8 +2257,7 @@  (define-public python-h5py
         "0pyr6z4h2xqbp49yx2i1401gl6yqh03h771zslwcy0201hpxiskg"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f ; no test target
-       #:phases
+     '(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-hdf5-paths
           (lambda* (#:key inputs #:allow-other-keys)
@@ -2268,7 +2267,7 @@  (define-public python-h5py
     (inputs
      (list hdf5-1.10))
     (native-inputs
-     (list python-cython python-pkgconfig pkg-config))
+     (list python-cython python-ipython python-pkgconfig python-pytest pkg-config))
     (home-page "https://www.h5py.org/")
     (synopsis "Read and write HDF5 files from Python")
     (description